Problem dimension dabase adalo

hi, I think there is a problem with the adalo database … I am verifying that over the 100 records I write, when I then go to read from the outside, only the 100 records are displayed while those after no … example 100 subscribe users, I do not see the 101 if I call it for example with API on the website I am creating. only I have this problem?

That is nomal,the API in one call returns max of 100 rows, you need to use the offset if you want to display more data. Check the API documenation:

The Adalo API only returns one page of records at a time. Each page will contain an amount of rows, which is 100 by default, but you can request fewer records per page using the LIMIT parameter.

hello, where and how do I insert OFFSET in my javascripting code: fetch (********************* ************ / collections / t _ ****************? offset = 0 & limit = 100, {
method: “GET”,
headers: {‘Authorization’: ‘***********************************’}
thank you

Javascript is not my cup of tea but maybe this Airtable post (Although Python) can give you some ideas.

thanks, but what should i enter in “itrXXXXXXXXX / recXXXXXX”?

The offset should be in the end of the API response, you need a table with more than 100 records to get it.

hi, for javascripting I managed to solve this way (adding URL offset at the end): fetch (********************************/collections/**************************************************? offset = 0 & limit = unlikely, {
method: “GET”,
headers: {‘Authorization’: ‘Bearer ***********************’}

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.