Publishing issue for webapp under adalo domain

Hi everybody,

I am asking for help because when I publish my PWA under, the request is not found…
It’s working as I use the previewer. Any clue about that?

Thanks a lot.


Can you show a screenshot for the setup of this publishing?

Hi Colin,

There is obviously something I’m missing…

Capture d’écran 2020-11-10 à 19.41.04

Hi @AntoineSLD,

Did you set up the domain for your app in the “Publish” section on the left menu? See screenshot:

I’m also getting the same 404 not found error.

I’ve setup the DNS entry correctly and the subdomain is forwarding to

Hi @CarlM,

It is a bit difficult to find the root cause of the issue without any information about the domain :wink:

Hi @Victor
Appreciate the help - i’ve setup on sub-domain which forwards to
I’ve made sure to select the created domain.

Hi @CarlM,

And what domain has you set up in your Progressive Web App settings? Can you please send the screenshot like the one above?

Best regards, Victor.

Hi @CarlM,

Here is the problem. You didn’t set up a CNAME record for There is A record pointing to, but no CNAME records.
There you’ve set up the HTTP redirection (301 - permanent redirect) to the address This means, that after trying, client’s browser is instructed to go to
And in your Adalo account this domain is not connected to any app - so Adalo replies with 404 Not Found.

You need to do one of 2 things:

  • either change the app domain (screenshot above) to (and be sure that this domain is set up in your “Domain” settings)
  • or set up a CNAME for, pointing to (and delete A record). DNS refresh will take some time. Also you will probably need to reset SSL certificates after (Domain settings, reload icon).


1 Like

@Victor you’re a legend thanks for your help!

Unfortunately I’m still geting 404 error not found when hitting

I’ve tried option two - Deleted A record & reset SSL certs. (the below images are the results)

I’ve also tried option two - same result:

Hi @CarlM,

For - you need to create CNAME record correctly. The one you’ve created is “”.
You need to have just “app” on the left side.


Thank you @Victor.

I’ve read your exchanges with @CarlM but I don’t get it.
I don’t have any website. I just want to publish my app even under the name
Do I have to set up a custom domain ?

Hi @AntoineSLD,

It seems that you have everything working :slight_smile:

Yes it does work now !
Thank you for your help.
As I get it now, if I want to publish it under an Adalo subdomain, no need for a custom domain. Just select none for domain and it should be ok. :slight_smile:

1 Like

Thanks @Victor. All working now :slight_smile:

I understand how DNS management works now!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.