Selected value in dropdown isn't updating in original screen


I have a use case screen where you can select the use case owner. When you click the current owner text field you are taken to a modal with a dropdown where you can select a new owner. After selecting a new owner and pressing save an action updates the use case and you are taken back to the use case screen.

What happens:
upon returning to the use case screen the original owner is still visible, in the database however the change has taken place. When I press F5 the new owner becomes visible. However I have tried several routes to make sure the use case screen updates but none seem to work. I’ve tried linking directly to the use case screen from the save button instead of just selecting back. I’ve tried both a visible and non-visible screen to confirm the changes and force a refresh. No luck yet.

Any ideas anyone?

Hi @Max_K,

Is it possible to show this behavior from a video? That would be really helpful to help here!

Thank you

Hi @dilon_perera

I don’t know why … but I cannot seem to replicate this behaviour, yesterday night late I gave up. today I wanted to show you what I meant in a video … only for the app to behave like it should :slight_smile:

Thanks anyway, I’ll close this thread.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.