SendGrid Authorization failed

Hi there,

Keep getting an error about permission denied and wrong credentials. I’ve tried creating new API keys on our SendGrid account, but still to no avail. See screenshots below:

Also, we’ve already authenticated our domain ( and a sender.

Greatly appreciate if anyone could help :slight_smile:

Thanks in advance!

That is strange, it seems to be setup correct. Same as mine:

As far as I can tell, this must be a problem with SendGrid and not Adalo. Have you tried contacting their support about this?

1 Like

Hey Colin, thanks. Will contact SendGrid and get back, thanks!

Hey Colin, do we need a paid account on SendGrid for the credentials to work?

I’ve tried using MailChimp’s and it’s working fine. But choosing SendGrid because we just need to their mail send API.

Quite frustrated because there isn’t proper documentation that addresses the 401 error status code on their documentation.

Thanks in advance

Quick update: I think it’s a SendGrid issue. I’ve tried successfully with SendInBlue also.

I’ll try to create a tutorial for SendInBlue and post it up on the tutorials subforum. Documentation is a lot clearer there.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.