Service Interruption — September 18, 2022

Hello everyone,

As of September 18 at 1:39 AM EST, Adalo has been experiencing a service interruption that impacts access to the database — in both the editor and the end-apps. Our AWS instance was auto-enrolled in an upgrade & has continued to re-enroll itself.

At the beginning of the interruption, our engineers tried the options that we have on our end to make the databases accessible & ultimately are waiting on AWS to bring our databases online at this time — either through the ending of this upgrade cycle or AWS manually turning off the upgrade.

Our status page was updated at the time of the incident & will continue to be the most up-to-date information that we have on this on-going interruption. Please make sure to continue checking the status page through resolution.

We understand this is extremely frustrating, not only for you, as app creators, but also for the users of your apps & for that, we are sorry. Unfortunately, this is an upstream dependency where our hands are tied in bringing this interruption to resolution.

Aside from monitoring the status page, this forum post will be updated once the interruption has been resolved.

Again, we apologize for this inconvenience & hope to have a resolution soon.

– Katelyn

1 Like

Did the Adalo servers get auto-enrolled without Adalo’s permission? If no, then this is extremely frustrating for us users. If Adalo had knowledge of this auto enrollment or upgrade, then the least that can be done is an email to all app creators giving us heads up.

Been getting nothing since morning but negative reviews and angry customer calls who cannot access the app. The reputation and revenue lost during the past 12+ hours is just beyond me …

I do not know what to say but everyday there is more and more reason to speed up the process of moving away from Adalo

Still not working. What should i do with my clients? They are wanting their money back. Will Adalo pay them? You guys should have warned about this interruption. I’m really considering switching to bubble.


Apologies are not sufficient I’m afraid, this needs fixing immediately and compensation offered to all affected.


It has been more than an hour since the last update on the status page. Can we please get an update? Even if just to say that you are still working on it?

At this point it has been more than 8 hours since the problem was announced.

As others have mentioned this is a nightmare from a user standpoint.

1 Like

Its back :partying_face:

We are back online now. The full details of this incident are available on our status page:

We apologize sincerely for the outage and will be working with AWS to make sure this doesn’t happen again.


Mine still no back online yet for editor mode. I hope it can be available for few hours.

@Aizuddin Can you try clearing your cache or jumping to a different browser? I believe everything should be functioning properly.

1 Like

ok, everything is back already.


1 Like

It’s not back on our end. Still showing 0 records. Anyone experiencing the same issue?

Our data collection records still isn’t back. Please fix this asap.