Since this morning opening a single modal will lead to black screen

Hello, since this morning I have been observing in both the Previewer and Released app that opening a modal leads to a black screen behind, with a small spinner at the top of the page…

It was working correctly until yesterday… Does anyone know about any recent change that could result in this behavior?

Maybe someone from the Adalo Team?



Try to replace the screen with a new one, maybe that will fix this issue. Also, make sure your app screen background transparency is set to 0%.


Hi @ishantanusrivastava
Why should I replace a screen that was working in production until yesterday?
Being a problem affecting Previewer and production (in my case 2 different app versions, with different layouts), why should it depend on a particular screen?

Maybe you can help me understand how to prevent those issue in future

Edit: even a new modal screen created from scratch (with transparent background) has the same behavior: the app is completely black while the modal is displayed. @Adalo_CXTeam

Update: I discovered that this issue happens on screens that have content loaded from database (I tried as a counterproof to create a screen with a fixed image and I see it correctly under the SAME modal.

This explains why I see a loading spinner at the top of the page without any content loaded… :frowning:

I am wondering what has changed on Adalo side to make this stop working… @Adalo_CXTeam

I have also opened a support ticket, but after days, still waiting for a response…

Hi all,
In response to my ticket, there has been a new release to the platform yesterday that solved this issue.
The modals are now working again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.