Stripe error: "An unknown error occurred"

I am trying to test my Marketplace Payment settings with a real credit card. When I try to check out, this error appears:
image
I’ve tried a few different cards, but none of them work

Is that error coming from Stripe, or is this an error from Adalo?

Thanks!

2 Likes

What do your Stripe logs (events) say?
That will give you some indication if the data is getting to Stripe

Hi @nocodemaker, I checked my Stripe logs and it shows the POST request as OK 200, but the charge is not in my stripe account.

It says Version: 2018-11-08, so I’m not sure if Adalo is using an outdated API for Stripe?

My Woocommerce transactions are going through with a 2019 API.

Also, the POST body from Adalo only includes the credit card info and I don’t see an amount or anything else being passed.

I just saw the Stripe test mode, turned it on, and tried it again. Got the same “An unknown error” message in Adalo with the same log results in Stripe.

2 Likes

I will have to check this with a developer and get back to you.

Thanks @Colin I appreciate it! I just tried it again and still giving me the same error. I think something is broken inside the Stripe component.

Just a quick update. The dev team is looking in to this.

2 Likes

Thanks @Colin I appreciate it! Just tried it again in test mode and I’m still getting the same unknown error message.

Is this still the case? I see that the bug has been reported as being resolved. If it is still not working. I will reset the bug ticket to not be resolved.

Hi Colin, I just tried it again in test mode and live mode and it still shows the exact same error.

Sorry for the problems @audiorush. We are looking in to it further.

Still the same, I tried now

@Colin just tried again with both a real credit card and test mode and both failed with the same exact error. Is this because the Marketplace settings/functions are broken?

I had this problem recently and removed the email section and left it blank. Try that and let me know.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.