Time zones in adalo

Hello, i’m making one app in adalo that based on time. From my database through integromat i’m receiving correct time , but then Adalo adds +3 hours to it. Is there anywhere settings where i can stop it?

I know that i can simply add -3 to formula… but i wonder why that’s happen?

Hi @Vitiniel ,

My guess would be that the underlying libraries that Adalo choose to build this builder are making them to do so.

To make it otherwise, it is not a priority to them, as it will be just unnecessary workaround, that is still solvable.

This issue has been brought up many times and considered, it is as it is.

Hi @Vitiniel,

Adalo internally stores time in UTC+0, and then applies the time zone of the “client device”. So, for example, if you store 12:00 AM, 01 May 2021, to some datetime property in a collection, and your device is in UTC+3, the actual time stored will be 9:00 PM, 30 April 2021.
And for someone in New York (which is UTC-04:00 in summer) it will be displayed 5 PM.

So, in your case, I would advise to check the settings in Integromat - which time zone does it use. As it has wonderful debug tools and you can view history of each transaction, you can easily track which time do you receive there and which one do you send to Adalo.

By the way, there is a timezone setting for Integromat account as well (mine was set to Europe/Kaliningrad by default for some reason, which resulted in some unexpected issues :slight_smile: ).

Best regards, Victor.

1 Like

Small update: I was meaning not just the time zone settings in Integromat, but also which time is stored in the actual records coming from DB and going to Adalo. Based on that you can decide what to do (either add an offset, or modify time settings, or may be check how the records are stored in the DB).

Best,
Victor.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.