Upload CSV "try again later"

I’ve been experimenting some troubles lately uploading CSV.
Last week it worked perfectly for about 300 rows but from yesterday on it won’t work.
I keep getting the message 'try again later" and “refresh” (see attached).
I’ve tried to refresh, log out, switch browsers, restart computer.
Any hints?

EDIT: I’m on the pro plan

Any suggestion on Adalo end maybe?
@pford @anon78309838

Can you try to change the file format to .txt and see if that helps? Long shot, but we had some makers who tried this and it worked for them. I’d like to see if it works in this case.

Thank you for your input @pford ! Much appreciated
I tried it and I have the same error + only one column is recognized

I had the same issue last week. I tried to import in 7000 records, and every time It imported around 800 then it said “try again later” or reload page. I ended up splitting the CSV into chunks of 500 and it worked. I also set up an Integromat linking the CSV from Google drive and running a scenario there to add records to Adalo. Both of these worked, but I never got it to work with the native CSV upload in collections unfortunately.


Gotcha. Thanks for testing! I believe we have a bug ticket already open about this, but please go ahead and submit one anyway if you don’t mind.


If it helps I don’t think it is quantity related. I tried with 50 rows and got the same issue.
Submitting a ticket! thank you
P.S.1: importing manually won’t work either telling “email already exists” whereas there is not email in the CSV
P.S.2: just found a solution: I copied my app and it is now possible to import!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.