Uploading images worked - now does not work anymore

Hi there - I was able to upload pics of 800kB size and more to my app project until this afternoon.
Then all of a sudden I am no longer able to (neither via macbook nor ipad).
Any idea what I should change/do differently?


Yes, confirming that image uploads via the “Image” component in the editor are broken for me also. Some seem to upload and others dont and just show a “broken image link” icon

I’m seeing this tonight too. Something going on on Adalo’s end it seems.

Hi there,

It works for me at the moment (just checked upload via Image and upload to a collection using Image Picker). Are you still experiencing issues?

Best regards, Victor.

Hi, unfortunately not. Still broken on my end both on mac and on ipad. It is a different “error” picture (green pixelated blurry mountain) than what you get when you try to upload large files (black mountain icon).

I’m experiencing the same thing! It just shows a green pixelated blurry mountain for me as well. #help

That’s unfortunate :frowning:
As I remember green pixelated mountain means that image can’t be displayed as it doesn’t exist in that URL. So it seems the image is not being uploaded to the storage.

I can’t reproduce this on my end - tried 2 different images of 6MB each - one uploaded as an image, another via Image Picker to the DB - both works.

My theory is this may be somehow related to a combination of network speed (your side) and uploads’ timeouts settings (Adalo side), but I can’t really confirm this.

It might be a good idea to submit a ticket to Adalo Submit a Support Ticket.

Best regards, Victor.

1 Like

Have you tried uploading an image that has never been uploaded to Adalo before? Images I’ve previously uploaded seem to work, anything new isn’t working. When inspecting the element, the image component is on the screen but the div which contains the css for background-size,repeat & position doesnt have a background-image set. Surely it’s something wrong on Adalo’s end. The placeholder image being displayed usually means that the URL is missing or incorrect from what the component expects.

1 Like

Good call! It didn’t work with a new one and I’ve got a 403 error for freshly-uploaded new image to Image component.
I’ve sent a notice to someone I know in Adalo. Hopefully they will fix that. Creating a support ticket still makes sense so that Adalo knows that many users are affected.



I exactly experience what Briggsy explained. Thanks for that Briggsy!
And thanks for sending a notice to Adalo - Victor!
Will also submit a support ticket.

1 Like

Update from Adalo Support :

Hi Dilon​,

Thanks for writing in about this, and sorry for the trouble!

We are aware of this issue and it is currently being worked on by our development team to get this resolved as soon as possible.

Although I do not have a specific time on when this may get resolved, I will be sure to notify you of any changes in the status of this bug moving forward.


1 Like

I also cannot upload images and it is seriously slowing down my workflow. Is the Adalo team fixing this in the short term?

1 Like

I have the same problem, has anyone opened a support ticket?

1 Like

Thanks Victor! Can you remind me of how to open a ticket?

Update from Adalo Support :

Hi Dilon,

We have reverted the codes that might be causing this issue and have replicated a successful upload at our end, could you please let us know if this is resolved for you?

Looking forward!

It’s working for me!

Can someone confirm it?

Hi everyone,

The problem seems to be resolved now.


no its not. I Cant upload any images… getting “Error validating image file type.” error

Can you add a image of the error? For me it works.

If you still get this error Submit a support ticket.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.