Users’ collection (default to any app) —— can I create (add) a record from a 3rd party service via API?

Hi,
Just a quick question on the “Users” collection.

I’m using Integromat/Make, which has an Adalo module “Add a Record” to create a record, to “any” collection. However, I’m trying to add it to the to USERS Collection, which is default to any new app, therefore I assume “special” (as it handles the Users and related to Signups, Logins, etc). I’m getting an error “500” and it says “Source: Adalo” (screenshot below).

Note: in Adalo and Make every works well (including the Make module Adalo ‘List Records’, ‘Get Record’). The issue is only when I try to use the 'Add a Record" to the Users collection. Is that collection not allowing external changes?

So, to summarize, I’m wondering if from a 3rd party service like Make, I could:

  1. CREATE (ADD) a record to the Users collection?
  2. UPDATE a record to the Users collection?

Thanks in advance for any help.

Hi @sweetapp21,

Found this post by Victor that may help you!

Thank you

1 Like

Hi,
Have you tried not using the Adalo functions in Integromat/Make and make a regular HTTP request in Integromat/Make?

image

2 Likes

Hi @sweetapp21,

It seems to be a weird issue somewhere in between Adalo and Integromat.
I can confirm that “Add Record” module, connected to “Users” collection, doesn’t work properly - same result as yours.
However, the record is added to Users collection.

I’ve checked same request in Postman and in regular HTTP Integromat module - records are added successfully.
So, as a workaround, you can use HTTP call to create user record.

I’ve submitted a bug to Integromat - will see what they answer. But I’m afraid this will be a ping-pong game between the support of 2 companies. Hopefully I’m wrong :slight_smile:

Best regards, Victor.

2 Likes

Thanks @Victor for the info and the for submitting the ticket to Integromat/Make.

I cheched again using Postman and the “HTTP module” in Integromat.

Here what I found:

  • ADDING records: I’m not able to do it to the User collection, but I can to any other collection
  • UPDATING records: this is working well without restrictions of collection or tool

In summary, the Users collections is clearly restricted for “adding”, so I’m planning on opening a ticket with Adalo support to confirm that is in fact the case. Hopefully will post again here any input from them.

Hi @sweetapp21, Seems for sure a bug on your side, yesterday I just tested adding users via the API and worked properly for me.

1 Like

Thanks @JL_LJ , good to know would be a ‘bug’ on my side.

Out of curiosity, what tool you used for “adding via API” (e.g. via Integroma/Make module ‘HTTP’, or module Adalo 'Add Record, Postman, etc)?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.