Integromat 'Update a Record' 500 Error Code

Hi all,

I am attempting to update records in a collection by using the Collections API. To do this, I am utilizing Integromat. However, when attempting to use the ‘Update a Record’ module in Integromat, I continue to receive the following error:


Has anyone else experienced this error and can give advice to move forward? This is essential for me moving forward with Adalo.

For reference, here is the entire scenario (even though I am receiving the same error on very simple other scenarios as well):


Hi @hoosier_nocode,

How did you set up “Update Record” module?

Also, just for information: after “List Records” the next module will be executed for each record in the list.


Here is how the Update Record module is set up. The RecordID comes from the List Records module, and yes I do do understand the next module will be executed for each record in the list. Currently have the List Records module set to limit 10 for testing purposes. But once I can resolve this error I will have a filter between modules to update the correct records.

The ‘Total Return’ field is being mapped with the Google Sheet to return a number - which is the according field type in Adalo, so I know this is working. Here is another screenshot I took from the browser console to show the body of the request:

Thanks so much for the help!

Hi @hoosier_nocode,

It’s difficult to debug such things remotely.
What I could suggest:

  • Try to remove “Entry” field in the Update Record part. I see it is an array, and Adalo API as I remember can’t accept arrays
  • Try to perform request manually in Postman with the same data and see what happens

As a general approach: you could try to remove everything from Update Record module, leave just one parameter (say, company name). Run the scenario and see what happens. If you still get 500 error - there is some fundamental problem with update, try to do it manually via CURL or Postman. If it works - try adding values one by one and see when it breaks.


1 Like


It was the passing of the array that was causing the error. I appreciate your help!

1 Like