Using RapidAPI with Adalo?

Hello Adalo Community!
Im very new to Adalo and would love to hear from anyone who has crossed this API hurdle already:

ISSUE
I am experimenting with setting up an external collection with an API from RapidApi. I did the following:
(a) Subscribed for a free API on RapidApi and received the values for “X-RapidAPI-Host” and "X-RapidAPI-Key"
(b) Followed the Adalo documentation in to setup my external collection.
(c) The result I got was an error stating "“message”: “Invalid API key.”
Screen Shot 2022-01-24 at 2.46.57 PM

QUESTION:
Is there a particular format in which the API key should be entered when using RapidApi? I tried copy and pasting the API key exactly as it was provided. When that didn’t work I tried inserting it in the format similar to this: https://example.p.rapidapi.com/?rapidapi-key=***************************

However I am still getting the error “invalid API key”.

Thanks for reading! :slight_smile:

Hello, did you get this resolved? I’m also trying to use rapidapi

Hi Zechari

I was not able to solve it, so I put it down for the time being. However I am still interested in resolving it!

When I find a solution I’ll let you know. I discovered rapidapi yesterday and can’t seem to connect it… have you looked into possibly having rapidapi connect to AirTable then have AirTable connect to Adalo?

Hmm, I was trying to keep my solution as simple as possible, so no did not try that.
Looking forward to see if we can make this work!

If you find a solution please share with me :heart:

Hi Gabrielle,

You have to put your API Key. You can find it in your Developer Dashboard. You can create a app for that relevant API and go to that App’s security section and a API Key will created for you and you can also create more API Key’s inside that too. API Keys / Key Rotation

Like this : For me it doesn’t works because I didn’t subscribed to this API Key. For you it will work because you have subscribed!

Hope I’m correct :slightly_smiling_face:

Thank you

Hi @dilon_perera !

I was searching CareerJet API on RapidAPI and I found this one: Job Search API Documentation (lattice-data-lattice-data-default) | RapidAPI

They have CareerJet option but their API is so slow. Do you have any ideas how to create own API by using CareerJet public API documentation? Careerjet public search API | careerjet.com

Or is there any possible you could create one for little $ price?

Hi Dilon
Thanks for your feedback. I will revisit this issue today and let you know if I make progress ::slight_smile:

I’m revisiting the issue now

Hello @dilon_perera. I followed your steps.

Here’s the url:
Https://nutritionist-api.p.rapidapi.com/v1_1/item”

After the word item I added a “?” followed by rapidapi-key= (inserted api key like you showed)

This is the result.

It’s quite possible to do what you’re asking for, my fee would be 200$ max.
Although please keep in mind adalo’s limitations, e.g. if the response of the API call is a list you’ll only get the first one.

Hi Zechari,

What happens if you replace the item text with a real item name?

Thank you

Hi Dilon
So I tried it again based on your feedback, and noted I previously didn’t use the correct format. Using the same format you did got me 1 step closer to success.

https://quotable-quotes.p.rapidapi.com/randomMantras?rapidapi-key= xxxxxxxxxxxxxxxxxxxxxxxxx

From the screenshot, you can see it says it “could not find any results”, yet it also shows me a result. Do you understand what is the “Results Key” it is referring to? Note I did not customize any of the settings for endpoints.

Thanks in advance for any advice!

After reviewing Adalo documentation a bit more, I see that its related to the “Get all records” end point I don’t see any info on this in RapidApi. I can’t save the external collection setup with sorting this issue out…

Hi Gabrielle,

Awesome!

Could you add a screenshot of the full response? Or can you test this on the API playground in Rapid API and add screenshot of that result?

I copy the full response below:

{
“id”: 12202104,
“body”: “Do great things.”
}

Is that clearer?

I made a couple of tests, and issue is related of the response of the API, seems Adalo cannot handle this , it is a JSON Object with one entry, it needs to be an Array.

I customized the API by turning to Array and it works, but this needs custom work unless someone has another idea.

Hi @Zwood,
You have the same issue has Gaby, the UPC scan returns a JSON Object instead of Array, Adalo cannot handle this.

What if I remove/ don’t UPC scan?