Weird issue with simple +1 field update


I’ve been struggling to get the simplest formula to work, adding 1 to the max of a column of numbers in one of my collections. The formula works in preview mode, but not in my builds in testflight or in playstore internal testing.

I tried setting the filed automatically at user creation, as well as later as an update action of the Users table. I tried deleting the button with the action and recreating it from scratch. Nothing works.

Screenshot 2021-10-28 at 16.06.20

Anybody have any idea what I could do? I reached out to the support yesterday but haven’t gotten an answer yet.

Thank you for your help!

I have seen sometimes these calculation variables are not updating fast enough or can only be used in certain condition, so we cannot put them anywhere we can when they are available.

You can try to save the value in 1 record collection and access this through make list component, so you can read and write last numbers.

I don’t understand what you are suggesting, just to be clear my goal is to have a user_id number which increments at each signup

The formula used to work in previous builds but is now not working!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.