Action did not complete

When I pressed “You bet” the record of the request is supposed to be updated. This has never been an issue before I have updated the user permissions so that those involved in the application can interact with it. Are there data variable limits I should be aware of?

this mean that there are some permissions in your database that doesn’t allow the user to complete the action, or just some missing data in that page

I just checked everything and updated my user permissions and I’m still having the same issue, why after two years is this a problem?

If this problem happened now, can you check the other collections permissions?

if not, please check if data is well linked into that page

My data is well linked, there are no errors that I can find.

Every action that is supposed to occur does aside from one change of a true false property and link to the next page, the user has permission to interact with the request. Are there data variable limits?

Hi Zachary,

Your collection settings are set to Everyone right?

No they are not set to everyone anymore, I changed them when this error initially popped up. I then followed through with testing on the newest iteration of the app with the updated permissions. Still having the same issue.

You have set Everyone to Logged in Users? If it is you are logged in right? What that Update action do?

The update actions confirms a rental request and allows the item requestor to pay for the product. It is still not working I set to "some logged in users "

When the Logged in user click You Bet button he/she added to a many to many relationship property?

Are you saying there are too many relationship properties involved?

I dont really understand what you’re trying to say. I appreciate the effort though thank you

I’m sorry if I not clear.

In your collection permissions try setting up to All Logged in users or Everyone from Some Logged in users and see if the problem still happening.

If the problem still happening check your Update action. If the action setup-ed correctly and still happening Submit a Support Ticket.

Thank you

I just did that right now, thanks for following through I tried a few different iterations with both all logged in users and some logged in users I check to see if any data was missing from page to page and that’s not an issue. So we’ll see what I’m doing wrong.

Maybe a silly question but you have logged in to the app right?

I had an issue with an action updating a number property of a user.

Used to work fine. Suddenly didn’t (in published native apps). Adalo confirmed this was a bug.

Only way to fix this was to remove the action. Re-add it and then push an updated app to the app stores


Thanks Steven for letting us know!