Another problem with the Editor today

Today some buttons in my app preview stopped linking. I didn’t change anything, I just went into the editor today, pressed the Preview and the some buttons stopped linking.
I even tried redoing them. In some cases it helped, in some it didn’t. And I have no idea how to fix it now. How to fix it?

At first, the “Does not contain Empty” function stopped working for me (about two weeks ago); now the links do not work. And I’m afraid to imagine what other functions in the application are not working correctly as before. Now I have to do a bunch of tests to figure this out.
What is the reason and when will it end? New surprises every day, It is very unstable and exhausting.

Adalo, when can I keep working?
Maybe you are changing something and I just need to wait until you finish and everything will start working stably as before?
I cannot prepare the assembly for the App store for the second week already.

p.s. And a question to the community: who has noticed problems in the last two weeks with their editor? Please let me know or I’m alone?..

Magic forum, as soon as I write something here, I immediately find a solution.
In general, see how it happened for me. I made a button and assigned a list to it and added a link to this list. Now the link action on the list does not work. Now I have to go inside the list with a double click and put the link on the BUTTON. Previously, the action on the list worked, but now it does not work. Damn, cruel! If that’s the case everywhere, I’m even afraid to imagine how many edits I need now. Why change it? It still worked great before. Adalo, do some kind of guide to innovations - there will be many more pitfalls in the future.

I believe this may be a bug related to a recent change made to lists. I’m digging into it further and have alerted the team about it.

Thanks for answering!
I believe in you

As far as I can tell, this only seems to be affecting lists made from buttons. If you create a list from a text component for example and add the link action to the list, it works fine.

I am at the moment uncertain if I would consider this a bug but more intended because a button should be used for performing an action, not the list. But perhaps it can be both. Could you explain your use case further on why you wanted to set it up this way?

It didn’t matter to me. I knew what could be done both ways. Therefore, I did not attach any importance to this and did it every time in different ways, knowing that it still works. But now it doesn’t work like that.
Colin, thanks for your responding! I have one more request, I wrote several times on the forum, also in this theme and also sent a ticket (522870906) to your team.
I have some kind of problem with the “Sometimes visible”, or rather with the function "Does not contain Empty "
Previously, it worked flawlessly, but now, when I creating new buttons, I had a problem with it. Regardless of the condition, the button is always visible. Please help with this.

Hello!
Another problem with the “Empty” condition:

This time it showed herself in the Chat.
After sending, the message does not disappear from the input line. It was ok, but it now working now. From the point of view of use, this is extremely inconvenient. Obviously the problem is with the Empty condition.
Adalo team please - pay attention to this! Many people, including myself, regularly use the Empty condition! We need it, but now it not working.


Hi @Colin

My use case similar to this is the following:

  • I have a list of buttons (that only shows one button at a time) to create a new Message in a Conversation but, in order not to have a big waiting time, I’ve linked it to a loading screen with a Lottie and then back to the previous screen.

  • The button simply creates a new Message with the text equal to a text field of the collection of which I have a list, and then immediately goes to the loading screen.

  • There, is where I update that new Message to determine which Conversation it belongs to and whose the Author, as well as update the Conversation and trigger a Notification.

  • What happens is that the Message is created in the database but the update doesn’t happen and the Message is not linked to any Conversation or Author. It was working fine before.

Sorry, but what is the problem or it solution? I wrote about “Empty” condition issue.
I very want it back to right functionality and I’m not interested in crutches.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.