Buttons with Links and Custom Actions not working

Anyone else having the issue where their buttons that have a custom action as well as a link are not working?

Screen Shot 2022-07-11 at 1.16.06 pm

It should’ve linked, and usually does. But for some reason today, my previews will not link when there is a custom action on the same trigger.

Hi Archer. We are experiencing the same issue. Have you tried building and testing the app on an actual device? Perhaps it’s just the preview that’s not working.

it’s happening to me also… I just posted another issue I’m having. Must be adalo. My app is live to the community and getting messages from people left right and center :man_facepalming:

Since the “performance updates” the button actions all seem to be slower now causing issues for me as well.

Yes same problem here

Yes same problem here

Published app and now users cannot register or login in. Anyone have any idea what is happening? @Michael maybe?

Hey @Burtverster @jmb2021 @roope257 @majdish09

So weird that you guys are experiencing the same issue now, when this first started happening to me I submitted a support ticket to Adalo, they seem to have fixed it the next day… unless it’s happening again in the last 7 hours.

But my recent builds testflgiht and preview are working fine as far as im concerned. Hopefully if you submit a support ticket Adalo can fix it

The same bug is happening.

It works in preview, but not for apps already published in the AppStore or Google play store.

No one is able to register to my app.


1 Like

Customer support responded to me about this issue.

They said that they could not seem to fix the problem with the apps already published in the AppStore and Google play store, and that the new builds are fixed, so please publish the new builds to the store.

Many of my customers are using versions of the app that have been previously published in the store.

So many of my customers are unable to use the app properly.

Some of my customers will write not so good reviews on the store.

I have been disappointed with several Adalo bugs in the past and this time I am even more disappointed.

Hi @RM08666, we can’t fix the problem with the builds that are already live in the Store because it involved some changes to code that is built-in with the app. That means you’d need to run a new build to have the latest code. This is not something we can change or workaround. One of the solutions would be warning your users to update your app.

I’m sorry that this caused you some problems, please share any info that you have regarding bugs and we’ll do our best and keep improving.

Thank you for explaining.

I understand the situation.

So why didn’t the Adalo team send me an email or something to let me know that users would be updating the app?

The sooner I was aware of this bug, the sooner I could have prepared a build.

I also think it is possible that there are other Adalo users other than myself who are unaware of this bug and are experiencing problems with the apps they have released.

Why don’t you and your Adalo team send out a whole build request due to the bug to us so that I can ask users who are my customers to update their apps?

1 Like

The weird thing is that Adalo fixed this problem for me the other day, but then testing the app today the app has the same problem… i feel blindsided cause i published the app cause i thought it was working HAHAHA

A new build seem to have worked this morning!

I have same issue. Weird because the same build was working fine before. Very frustrating

1 Like

Yeah exactly!!! Got us mad hahaha but adalo does great things so I forgive them!

I’m sorry that the communication wasn’t smooth, and thank you for your feedback. We’ll work on this so you won’t go through this same problem again.

Are you still having issues?

I submitted a new build (no relevant changes) and it seems to be working fine again. Thanks


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.