"Link" doesn't work

“Create” and “Update” works but only “Link” doesn’t work.

Definitely, it worked yesterday and the same set up of another my larger app worked as well.

However, it turned to today, they dont work.

I deleted the button, the list
and the page one by one, but not working.
how should I do this?

Or, will it work when I launch it on the App Store?

1 Like

Hey, is the link function working on other buttons? Because I had the same issue where one of the buttons in a list wasn’t asking linking to the next page as it was programmed to do. Perhaps it’s the same issue and not an us problem?

Also, does it work in a testflight? I’m about to test it so I’ll let you know.

1 Like

I have found it that adding more than two actions(the one is “Link”) make it impossible to work.

Really? That will be so helpful!
I will wait the result of your try, thank you @Archer .

Yeah so i have just tried on the test flight and buttons that were working fine with like 6 Actions now do not do all the required actions… Why? Perhaps it’s just being super super slow with some actions? or perhaps is not even reading the action at all.

As you can see in the image I have a button that has all these Actions. The “Change Input” hasn’t worked either.

Screen Shot 2022-04-20 at 3.35.43 pm

I have also had the problem with a back arrow that should be taking the user back.

Screen Shot 2022-04-20 at 3.45.08 pm

This wasn’t happening last week and must be an issue from Adalo’s side?

Hope this helped, I will be emailing Adalo support as well.

Two recommendations here:

  1. Keep the naming of your screens as simple as possible. I believe that in your example, the naming could be causing the conflict/issue.
  2. No more than 3 conditional actions together. Ideally you only have one or two at the most.

Same issue here, the strange thing is that on the adalo.preview app in works but not on the published domain. (no issue detected in the console)

Have you guys tried to duplicate the screen that’s not linking properly, and then link the action to the new duplicate screen and see what happens?

1 Like

hi @charleshope , just tried but the issue persist. The issue happens when combining a “create action” with a “link action”, as if the url parameter can’t be built

1 Like

Hi, @charleshope
I did as I mentioned like this, but “Link” does not work.

I also have similar settings on my app. I have just tested this on Previewer, through the URL and native, and everything is working.

I recommend talking with Adalo support.

1 Like

Same exactly.

1 Like

i reported the same problem last night,

on preview link is good on url and share isn’t working.

and now i have my app and costumers not able to buy anything, something broke
@Colin any idea?

did you get any response from them yet? the issue seems impacting lots of app, so hopefully they will bring a fix very soon… but same for me all my client users can’t make any orders or other create actions

not yet, they are in the US so it’s night time, hopefully this will be a simple problem to solve,
i have my business literaly stoped today.

I have sent a support ticket, so I will tell you when I get reviews from them.

2 Likes

High. I have the same problem. I suppose that the problem could be linked with a problem with the use of current date (in creation action). No screen is abble to recognize current date… Could somebody check that… All screen using curent date are down (no display of the current day) no link after a creation of a record using current date. The record is created but not properly.

1 Like

ADALO does not recognize current date. I suppose it is why there is a problem…

1 Like

hi @imjohnston , do you know if the dev Team is working on fix for that general issue? cheers

Same bug here

1 Like