App crashes after attempting to sign-up

This issue is present in our live app and occurs after users attempt to sign up. After submitting their personal details for an account, they are directed to a black screen where no more action can be taken, indicating an app crash. The accounts are still created in the Adalo database despite this crash, and the new users are able to log in after force-closing and re-opening the app. I’ve attached a video showcasing this issue below.

(password entering was removed automatically by screen record)

This issue only occurs in the app and test flight builds of the app. The Adalo previewer works perfectly for the sign-up process.
We have tried installing past versions of test flight builds which had always worked before, but now they also experience this crashing issue after attempting to sign up.
We have tried removing all custom components from the screens surrounding the sign-up process but the issue persists.
We have contacted various third-party developers who built these custom components for debugging, and they have confirmed that the custom components are working fine and shouldn’t cause the issue.
This issue seems to happen intermittently. Sometimes users are able to sign up without experiencing the crash, but later attempting to sign up causes the issue again.

The app is only released for IOS, where the issue is being experienced.

We’d greatly appreciate any support, as this issue is affecting a lot of new users and causing users to uninstall the app.

Hi @JP202,

Seems that this issue will require some help from support. You can submit a ticket here: Submit a Support Ticket.

Meanwhile you can try to investigate by yourself. You can have a look at app crash logs for iOS:

  • Navigate to the Settings app.
  • Tap Privacy & Security.
  • Tap Analytics & Improvements.
  • Tap Analytics Data.
  • Select a crash log from the list in alphabetical order.

If you have Mac, you can share the crash log to it and then you can view its contents in a structured way. There might be some hints in the log, however, maybe you won’t find anything.
This thread is worth reading:
App immediately crashing from TestFlight.

As a side note: all the time when I saw app crashes, the app either ended on a white screen or closed immediately. I’ve never seen a black screen before. Maybe this is because of a screen background (??) or the app doesn’t crash but is simply stuck on some screen (??). Crash logs should help to indicate that.

Another thing what I would do - is to rebuild the signup screen and the following screen(s) from scratch, removing all extra components, and see if the app continues to crash. I see that you’re using Apple Sign-In and Google Sign-In - I would try removing them as well. Of course this should be a temporary testflight build and it will never go to production - you’re going to be doing it for testing.

Also it is quite strange that previous builds stopped working as well. If that could be proved, then logically thinking there is something changed either in iOS or in the backend, which now causes the app to crash. In the backend I can imagine some issues with the database (e.g. collections permissions? maybe you’re trying to write something to a user collection which doesn’t work?), or some settings in the Appstoreconnect/AppleDeveloper (certificates?), or some changes in the custom actions(?), or some other Adalo backend issue (maybe you’ve run out of actions or something like that?).

Sorry I can’t give you a recipe here, but hope these options can help you to explore the issue further and find the solution.

Best regards, Victor.

1 Like

I can be wrong, but might be you’re navigating to next page, that is crashed.
I’ve seen similar issue recently and issue was that user was navigated to view with IAPHUB start component that crushed.
Did you check this case?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.