Buttons with 'click action' (to advance to next screen) work initially, then suddenly stop working

Hi,

Minor but very odd issue (feels as if my entire Adalo ‘app’ is corrupted) — in Preview mode, buttons with ‘click action’ (to advance to next screen) work, then suddenly stop working

What’s odd is that it works just fine initially (I mean in Preview Mode), then minutes later the same screens and button suddenly stop working. Trying to understand the issue I add blank screens where all I add is a button that links to the next screen and even those ‘new empty’ screens are getting the issue minutes later.

Here a screenshot and two videos recording my screen (each video is an example of the same issue).

Appreciate the help. It feels as if my entire Adalo ‘app’ had got corrupted … could that be possible?

Interesting case.

What happens if you simplify the naming of your screens?

It may be the case that your naming convention for the screens is the one causing the issue.

Test by using simple names for your screens. For example, Screen A, Screen B, Screen C, etc. Just for testing purposes (you can always change them back afterwards).

Once you have changed the screens’ names, please reload your browser and check that the names are correctly updated, and then try again.

Please, let us know how it goes.

2 Likes

Thank you! I was thinking about the naming of the screens too (as I had rather long and kind of complicated names).

I just tested with simple names (Screen 01, 02 etc) and there is NO issue. The thing is I’ve seen the issue appear several minutes later (perhaps when I rename the screen).

Will try “keeping” the screens names simple. Will try to update here.

Thanks for the update.

Since it works when you change the screen names to something simpler, please, open a ticket with Adalo support and provide all the details (the issue and the workaround).

This is important because it will allow them to look into the naming issue when the screen names follow the format you were using.

Thanks again!

Unfortunately, I tried the renaming of the screens for something very short and simple and it didn’t work

Below is a screenshot of what I did: I had two screens (those were not working before, i.e., the button was not working in Preview Mode), I renamed them for something short, “Screen04” and “Screen05”. I tried Preview Mode and confirmed the issue persist. Here also a recording of my screen showing that, how in Preview Mode still doesn’t work: Loom | Free Screen & Video Recording Software

Unfortunately, seems like the only path I have now is start a brand new ‘app’ in Adalo and recreate every single screen. This time for sure will start with short and simple screen names. I assume/hope that would fix the issue, otherwise would be an issue not wiht an app but with my entire Adalo account.

Will try to update here. Per your suggestion, for sure opening the ticket with Adalo Support right now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.