Can somebody please advise? My location is working on desktop preview, but not on mobile

Hi All,

I am newer to Adalo and enjoying it so far!

I am having a problem where the device location is appearing in my app when previewed on my computer; however, the device location is not showing when viewed as a test on my mobile device. At the bottom of my mobile, an error stating “Location data is not available” appears. Note: the addresses of the business locations work fine, but not the device location. Also, this is saved as a bookmark on my mobile and not a live app, if that has any correlation…

I have tried to troubleshoot this for some time now, reviewing all the the Adalo support info as well as past Community threads. However, I have yet to be able to resolve this problem.

I have checked my Google maps API and billing as well as turned off all restrictions. I (believe that) I have also configured the settings in Adalo correctly, but still I am missing something! Please also note that I am not receiving a request on my mobile that is asking for acceptance to use current location as some of the troubleshooting tips elude to.

I appreciate if anyone may provide me some direction / pointers on this matter!

Thank you,


Hope you’re doing well.

Make sure you give the permission to browser you are using. From notes, I think you are using safari and in safari, you have to enable the location from settings.


Hi Shantanu,

Thank you so much for your reply. I have just double-checked my Safari location settings and they were set to “Ask”. I have since changed to “Allow”, but still no luck, see below:


To provide some visuals of my problem, I am attaching some screen captures:

  1. When I click in the location field, it appears that it will work correctly, by asking to use current device location:

  1. However, when I select “Current Device Location” (bold text), it just disappears and goes beck to default field:

  1. Further, the Location error below appears at the bottom of my screen:

Any further ideas as to how to resolve this is greatly appreciated!

Thanks again,

Hi Adalo Community,

Any further advice here?

Thanks again!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.