Custom Domain DNS Setup Help With Google Domain

Hey everyone! I am having issues with setting up a custom domain (I use Google Domains). Attached is a screenshot of my DNS setup. Appreciate any help!

I also use Google Domains actually. Two things here:

  1. I don’t think you need a subdomain forward unless you’re trying to something very specific.
  2. Instead of putting the full URL as the Name in your DNS record, you need only to put app which you already have in that first record so the second record is not needed.

Thanks for the response @pfordmedia !

That’s interesting to hear because I thought the subdomain forward was what told Google to pick up the “app” part of the URL since the URL i purchased is only “www.batonreturns.com” (ie. not “app.batonreturns.com”)

On your second point, I orginally only had “app” under CNAME records, but it was not working so I added the second CNAME with www.app.batonreturns.com.

Not sure if you have any other suggestions since I’ve already tried what you said?

Yeah it can be frustrating to set up. My advice is to delete the subdomain forward and the second record, then give it about an hour to update the DNS. If it’s still not wanting to do it, I have noticed that sometimes you have to delete the domain in Adalo and retry the connection from scratch.

Hi @chadblumenthal,

As I see now, you’ve set up the subdomain:
app.batonreturns.com - which points to hosting.adalo.com (all is correct in Name Records)

Now you just need to set up everything in Adalo - add “app.batonreturns.com” as a new subdomain for your app.

As for what you’ve purchased - usually you purchase the 2nd level domain (i.e. batonreturns.com). And after that you can create as many subdomains as you want.

Best regards, Victor.

Hi @Victor thanks for the response!

Can you clarify how to “add” the new subdomain in Adalo? I thought that is what I already tried to do in this screenshot. But it didn’t work.

Hi @chadblumenthal,

On the very bottom on the screen/modal, you have the following input:

You can add “app.batonreturns.com” there.
On your screenshot you’re adding “www.app.batonreturns.com”, which is a different one :wink:

Best,
Victor

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.