How do I redirect to desktop/mobile app?

Hey I have two apps sharing the same database. How do I make sure desktop users get to the desktop app and mobile users get to the mobile app? (eg. “m.website.com” “website.com”)

1 Like

There’s not currently a way to do this within Adalo, but your DNS provider may support a mobile redirect.

1 Like

I haven’t found any way doing this through my domain provider solely. Specifically in this project I am using also a hosting provider for my blog so I directed all of the traffic to the hosting and from there redirected through “.htaccess” file the users to the correct CNAME depending on if they’re coming from mobile or desktop.

This worked out in this very specific situation, but what if tomorrow I want to make another app for myself or a costumer I’m building a project for and needs it to be compatible for mobile and desktop?

Hello,

maybe a domain and sub domain ???

Hey, yes this is not the problem. I have my desktop app on “www.mywebsite.com” and my mobile app on “m.mywebsite.com”. the problem is that without access to somthing like .htaccess file, I dont see how can we do direct the users to the right app, on the right address.

Hello.
Can you please share a valid .htaccess setting to create this redirecting from Adalo app to desktop and mobile versions?
Thank you!

Hi @ionutilie,

Not directly answering to your question - but you might find this useful:

Best,
Victor

1 Like

Thank you, @Victor for your info.
I am using now MFork and it is a great solution.
The only limit is that redirects only to subdomains and not to the main domain.
So, if I want to redirect the desktop version to the main URL this is not possible as it will be 2 CNAMEs for the same registration.

1 Like

Hi @ionutilie,

Ok, I see. May be you could contact @franklbtm and ask him for an advice. As I understand, he uses some external service on Azure to determine whether the client is mobile or web.

Best,
Victor

1 Like

Hi @clementmonbonpro ,

Sorry for interfering - for me everything works: when I opened www.monbonpro.fr, I was redirected to web.monbonpro.fr, which is I assume the correct result.

Most probably you have the old record cached, just need to wait for 30 mins.

Best regards, Victor.

1 Like

you’re right victor, I indeed just needed to wait 30min… :wink: Thanks !

Since you help me so much, do you know how to solve this (when using mfork on www.monbonpro.fr) ?

And what does it say in the “details”?

You might try to refresh SSL certificate in Adalo settings for this domain

The certificate name "azurewebsites.net does not match the entry… aha sorry I’m not of much help

Ok, I’ve reset the all mfork and now it redirects perfectly.

Only refreshing the Adalo SSL certificates wasn’t enough. Thanks @victor for your help !

1 Like