I can't add favorites


I am having trouble with adding favorites to a user, exactly as shown in the “directory” template with dates. I use my own blank template with pubs instead of dates, but I copied the screen from the directory template where you can add certain dates to your favorites. However, it doesn’t seem to work. It seems as if I have the exact same settings for the actions and yet the buttons do not seem to work. In preview, when I press a button to add the certain pub (date in the template) to your favorite the little loading dots just spins around and nothing happens. I have no idea what I have done wrong, it should work, and I’ve furiously searched for the problem with no advancement. Has anyone experienced the same problem? Is there anything obvious I might have forgotten?

Thanks in advance!

To specify: the buttons load as if to remove/add date (pub) for a second, then resets as if nothing happened.

Also, there obviously aren’t any dots spinning around, as I instinctively thought :slight_smile: it’s just a normal loading circle

Hi @Anton_KSG,

Could you possibly make a short video showing the problem and the settings for this “add to favourite” buttons?

Sometimes the endless “spinning circle” on a button might appear when no action is attached to it (you could try it by yourself). If it’s not the case then some more info is needed.

Best regards, Victor.

Certainly. Apologies for the late answer, I have been away for some time.

I created a link on a file sharing site I found. Here it is. The password is Adalo123.

Since my app is in Swedish, some words need an explanation. “Krogar” is my name for “pubs” (krogar in this case is both singular/plural). Favoriter means favorites and “favoriserad av” means “favorited by”. “Namn” means name. In fact, pretty much everything is directly translated from the original template.

As I tried to show in the video, I think I’ve done everything correctly, yet evidently, I haven’t. The button doesn’t add the user to the pub’s “favorited by”, nor does it disappear and show the other button… Don’t know what I’m doing wrong. I hope you might think of something.

Thanks for the reply,

Wow, I have no idea what I did, but apparently it is now working :). I just fiddled around a little with the settings and the database relationships, and then it just worked. To the person viewing my video, thank you so much, but now it’s fixed.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.