Ican't see My Webapp on my domain Not Found error

hello guys it’s me again and I am trying to publish my WebApp On my custom domain
and thanks to the community’s help I managed to add the domain to my Adalo account
published on

BUT !! When I go to Twsela.org which is my domain’s name I don’t find anything
here watch

although when I Click Open from Adalo it goes to the domain and shows me this

I waited for sometime before I post here and searched some topics but couldn’t find a match
I appreciate your help .

You are trying to access twsela.org, and yet you set up in Adalo Twsela Desk.

tried that already
Same error unfortunately

Not a expert using domains :melting_face: But did you tried refreshing your SSL certificate? ( how : WebApp on custom domain - website not secure - - #5 by axme )

Same error still Exists

check this out I went to the domain rules and gave it some redirect records and it worked

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.