Adalo SSL Certificate Failure

Hi team, I’ve tried to log 2 tickets but no luck in getting anyone to resolve this issue. I’ve now tried the following:

  1. Reset SSL through the Domain Settings - 3 attempts over 2 days and this did not work
  2. Create a new CNAME Record and attempt to use this - This did not work and I am still getting the SSL Error.
  3. Create a new CNAME with a completely different Domain - This also did not work and I am still getting the SSL Error.

The SSL Error is only happening against my PWA Mobile App. Other Desktop Apps is not experiencing this issue.

When I revert back to the original default domain: - This works perfectly without the SSL Error.

Do I need to pay and setup my own SSL Certificate through my Domain Host CrazyDomains in order to fix this? I thought SSL was provided for by Adalo?

I’m really hoping someone can shed some light on this strange problem and resolve this. Its a really bad user experience and in most cases, end users exit without clicking on Advanced and Proceed anyway. I hope this SSL Error does not cause security risk and weakness for hackers to penetrate.

Hi @furmconsulting,

Welcome to the community :partying_face:

There is issue on resetting SSL currently! See this post : Web App Custom Domain SSL Error - #35 by Vitaly

Monica From Adalo Support said :

Hi Dilon,

Thanks for writing in about this!

We are currently aware of the issue and the team is actively investigating the cause. Unfortunately, this was caused by AWS end so we are currently working with them to help solve the issue.

We will provide updates there as soon as we know more!


I will update this topic when I got a update from support!

Hope this will be solve soon!

Thank you

1 Like

Same issue:

Hi Dilon, any update?

I don’t think so

Did you reset the SSL Certificate?

SSL reset
Now it works!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.