Need help modifying an external Collection (API) data type

I successfully connected a couple of my Wordpress/Woocommerce API endpoints.

However Adalo seems to decide byt itself the type of property each data type should be.

I am stuck with the order total being saved as a text. Meaning i can not use it for calculations. I have tried editing and saving the property from texto to number and it does not take.

Here is an example of an order.

Any help would be appreciated.

Has anyone encountered this?

So far i have tried importing my data from the api using the actual api endpoint. through google sheets and then Adalo and from air-tables and then adalo. In each case i cant modify the data type.

The closest i been able to do is to have google sheets through a cronjob import data into a spreadhsheat from the api. then have zapier detecting any changes and then passing that data straight to adalo via its api and feeding an internal DB.

We do not currently have a forumla property. You can bring this field in but will not be able to create or update it.

@diego Have you made any progress on this? What have you been able to accomplish with Adalo Wordpress/Woocommerce?


I basically had to jump over many hoops to be able to use the data.

Adalo lets you import the data from Wordpress/Woocommerce or most other APIs, however you are note able to format the data. Adalo decides if something is a number or a string (text). After trying a bunch of potions. Wordpress to Google Sheets, or WP to Airtables or like 5 more combinations I needed up just paying for Zapier.

I have used Zapier in many other projects and it is great. I had to work a bit on the Zap but I was able to add the dates, and other fields in the format I wanted. Particularly tricky is the date time format.

@diego You can change the property type for external collections properties. Once you’ve set up the external collection, expand the collection in your data tab to view all the properties, then click on the property you want to change. Now you can select the property type.

1 Like

Hi Ben,

If that is the case then I am encountering a bug. Cause I try changing the data type and it never saves. I tried changing the total from text to number and I could notget it to work.

In any case I later had to reformat the date time fields and I did it with zapier,.

Yes…in 2021 April, this is still a bug that is still around. I cannot change the type for one of my external data. As a work around I had to open a collection in Adalo and then use Pabbly API connector to update the record there.

It is critical to have the type for external record be changed for example from a text time to a number type. Otherwise, a creator cannot use SUM or any any calculation on that data column.

Hi Ben - is there any plans to address this bug?

i have the same problem of diego:
I’m trying to change the type of the field from text to number but when i save the change was not applied.
Any news?

Still not working. Is this ever going to get fixed?

Still no fix…

Having the same problem. My external collection sends this data:

"messageTimestamp": "2022-02-07 18:00:00"

but, I cannot change the data type from “Text” to “timestamp”. Pls help.

You need to make sure your backend is sending the responses as date/time or timestamp rather than text. What is your backend based on, laravel, node?

1 Like

Thank you for your question. I am actually connecting an Aurora Serverless MySQL backend from AWS. Based on your inquiry, I said to myself, “self, what format will Adalo really understand it is a timestamp?”

That led me to the ISO 8601 standard and when I use this as part of my SQL, I get Adalo to recognize the timestamp:

SELECT DATE_FORMAT(date, '%Y-%m-%dT%TZ')

Problem resolved :slight_smile: