Problems with Airtable, it does not save in the database

Hello, I need help with AIRTABLE, I am building a community app where users can publish products, I integrated with AIRTABLE but the problem is that when I create a product in adalo it is not created in airtable

Hi @Santiago,

There is a problem that not creating records through the form in Airtable and the support said they are working on it. I will Update here if Support gave a Update! For now, using a custom form worked for me!

Thank you

1 Like

Brilliant. Thank you very much, I will be waiting for the news!

Better have a seat, I have this issue for a long time (1 year, which made me stop using Airtable), and still not solved, 2 weeks ago I opened a ticket since I have customers that want to use Airtable, support told me they are aware of it, but no estimated date to when this will be fixed. The workaround for now is creating custom forms with API calls to create/update fields in Airtable which sucks hards in my opinion.


Yes, you’re right, I was looking at that possibility or that they reach me by email and we manually transcribe them to the airtable…were you able to make the api call? Would you share with me to see how you did it?

@JL_LJ you mean creating a custom form with Inputs, Pickers and add a button and add a Create action for that collection as we are doing for normal Adalo collections and filling the fields in the action with Inputs, Pickers? Or you mean a Custom form with a Custom action?

I guess the Custom form with the Create action.

For me the the Custom form with the Create action worked!

1 Like

Doesn’t work for me. Only this method “I guess the Custom form with a custom action.” works for me.

Great… do you have any photos or video of how they did it?

Add an input field for example instead of a form:

Then a button:

With action “Create” and choose Airtable collection:

And then you only need to add data to the necessary fields:


Great, I had tried that but it’s not working for me…

I did the same and for me it works! Adalo support also said for now as a workaround use inputs and button.

Did you fill the create time and Id in the action? Can you take a full screenshot of your full Create action?

Are you updating or creating a record? For creating you don’t need ID, but for updating you do need the ID.
In my case, I had only 1 to fill in data, the 2 first are created by airtable, and the 3 last ones are just formulas, so I only filled in “page_ID”


Hello, thanks, I was able to solve it, it gave me an error because I put the current time in the time of creation, I deleted it and it worked great there.

Now I have a query, how do I filter the list? It is a list of products that has the mail of the logged in user, so I want to make a filtered list of products mail is equal to the mail of the loggead in user

1 Like
1 Like

Great, one last question, in an app when I upload a product, I add that product in one day (adalo database). It is a toggle that says this product will be available this day, now, how do I do it when that product is uploaded? in air table
Crear then link to select days

in airtable I made a field that says Day, then when selecting the toggle in DAY I save the name of the day, but it does not update it

You mean like when you click the toggle show the product if not don’t show?

If you want, I’ll give you the link here so you can upload a test product and see the process, upload a promotional product and then select the day you want that product to be shown!

users can search by discount % or by day

I want to use airtable because they will be unlimited products and in the long run I’m afraid of storage…imagine +1000 products on photos haha

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.