Publishing, cannot connect to my custom domain!

Hello guys, have tried everything but failed to connect to my custom domain☹️! The update after a few minutes jumps to the home screen! Any ideas how to sort this out?

Have you updated your settings with your registrar to reflect what is said in that first screenshot?

Which registrar is your domain registered with?

Yes i have already updated the details with my registra. It’s a South African company called vehost!

Did you include the period after the .com for the name? Can you share a screenshot of the setup of the dns in your registrar?

Hey Collin,

The guys who handle my DNS did that for me, here is the screenshot I requested.

Hi guys, have the same issue since yesterday. I did it in the past with another app and it was working. @Claire: did you try iOS/Android publishing? I am wondering if entire ‘publishing’ has some issues

Looking at your screenshot, seems your DNS record is configured incorrectly, you have record:

www.afrikanhat.com.afrikanhat.com IN CNAME afrikanhat.com.

look at the row 10 (the one with CNAME) record. In “Name” column there is no trailing dot (".") after “www.afrikanhat.com”. So, most of the name servers will treat this name as not FQDN (Fully Qualified Domain Name), but as a part of other domain name - in your case afrikanhat.com.

You need to have a CNAME record in your domain, which directs to hosting.adalo.com.
For example, if you want your app to be hosted at the address myapp.afrikanhat.com, you need to add a record
myapp IN CNAME hosting.adalo.com.

1 Like

Hello Victor, thank you for your feedback. I sent your feedback to the guys who handle my DNS and they corrected the record and the updated well without stopping halfway and jumping back to the homepage but still there’s no reference to my app when I type the url afrikanhat.com or afrikanhat.adalo.com! I do know what else to do.

@Kinga did you use the ios&Android to get your app online? If that worked for you then I think I must do that coz this DNS / Domain issue seems to be taking longer to be corrected than I expected :pensive::frowning:!

Another thing I don’t understand is why isn’t atleast my subdomain the afrikanhat.adalo.com not working???

That is the screen shot I get whenever I type in the url!

Hi @claire

  1. Seems that CNAME is set up correctly now:

$ nslookup www.afrikanhat.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
www.afrikanhat.com canonical name = hosting.adalo.com.
Name: hosting.adalo.com
Address: 54.224.90.229

  1. What you need to do now, is to connect your app to this domain (www.afrikanhat.com). It’s the same interface you’ve presented on your screenshot. Go to “Publish” -> “Progressive Web App” -> section “Domain” -> “Add Domain” -> “Add custom domain” and add www.afrikanhat.com

By the way, DNS works in a way, that records are “cached” on other servers for some period (this is called TTL, see column, measured in seconds). So when existing DNS record is changed, the changes may not be available instantly, you have to wait for some time.

As for “afrikanhat.adalo.com” - I don’t know how it should work :slight_smile:

If this still doesn’t work, I guess I can’t help anymore and you will have to ask someone from Adalo team.

ios yes, but there are issues re Android build :frowning: check this thread - Android Build Error / iOS build stuck in Queued Status

Hi Victor,

The domain has been added now.

but I still cannot get my interface when I put in the url…wow this is frustrating :frowning: and exhausting!

www.afrikanhat.com is still giving me this!!!

@ Kinga Eh​:fearful::disappointed_relieved: ok. This situation seems hopeless! Anyone from Adalo team can you please help!!!

Hello Victor,

Finally my domain works now! Thank God! I hadn’t saved the domain name, I just updated it that’s why it wasn’t working! Finally! Am happy. Thank you :blush: thank you Victor. I really appreciate your help.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.