Query Parameter with Airtable

I would like to show a list of posts for the current author, and I tested with my email and it works


However, it does not work if I inserted ‘dynamic user Email’ ( Logged In User > Email) to the parameter (Tested with logged in user)

1 Like


I have the same issue but with an ID. Can’t figure out how to make it work

I have the same issue.

I spent a while trouble troubleshooting it.

Even weirder - during testing, I set up a text input, then Dynamically loaded ‘logged in user email‘ into the input on page load. I then used the input’s value as a dynamic filter in the list (in the same spot as in your images).

THAT works. Meaning that using dynamic ‘logged in user email’ info as a list filter doesn’t work… but using it INdirectly, pulling it into the list filter via a text input on the page first, does work.

@jeremy, thoughts?

1 Like

Apparently this works for some reason odd reason… Now I get the right info displayed

So an update to this.

Weirdly, if I use the exact same hack/workaround I described above - to get a ‘Count’ in a text label (using a ‘Formula’) - in the same page… that doesn’t work.

It returns a count of all items instead of a count with the filter applied.

Hello everyone someone have the solution ? Impossible to link an “Airtable user email” to an “Adalo email user”


Hello Everyone!
Even I had the same issue and support people gave me a work around with which I was able to solve this issue.
The issue here is that the way the screens load the table is not able to load the user email all in one as you have set up. To work around this you can have a blank screen before this screen that transitions by none in which through a text component and magic text you have the logged in users email on that screen (it can be white/hidden to not show). We have also seen users put a text field with magic text logged in users email on the screen with your table hidden under an app bar or hidden on the page so that the page loads the logged in users email and then the airtable filter should be able to pick that up.

Give it a try and see if that works for you.

1 Like

I think the field name you’re searching for needs to be in {} instead of just by itself.

The {} does not solve this issue. I’m also using the input box workaround on many pages, but it is a little clunky and slow. Would love to see this solved.

1 Like

Hello, I’ve been having the same problem with my app, which I’ve mentioned in detail here. Good to know that it’s not just me though, and I see that there’s a workaround here. I’ll give it a try and see if it works, and if there’s any other good solution that I can figure out too

Hello @sriramganesh, thank you very much for posting this! Worked like a charm. Can confirm that this is a good solution for this problem :smiley:

I’ve created a bug entry: Airtable filter is bugged | Voters | Adalo

Would be great if you guys can also vote on it to increase its visibility:
@pford @scriptchool @j.renaud @AJAY @Dim @sriramganesh

Even with the workaround (placing an input field in the same page, and the list filter using that value for filtering) it sometimes works and sometimes it doesn’t. If I refresh the page with F5, sometimes the page displays the correct data with the filter applied, and in other times it doesn’t, like 50-50 chance. I noticed this happens more when the filter formula is longer.

I’ve also noticed another thing that might help in pinpointing the bug further. If I retype in the correct filter value inside the input field, then the filter works again. Say for example, I’ve set the default value in the text input field to show “Done”, and the filter to pick up data with {Status}=‘Input field’. When the page loads, I can see that the input field is showing ‘Done’, but the like I said earlier sometimes the data set does not reflect that (have to hit refresh and then it works). However, if I manually type in ‘Done’ in the input field (or just hit backspace to delete the last letter and retype the last letter again) then the filter magically kicks in. I don’t even have to refresh the screen in this case. So my guess is that maybe the filter function in the list is having some trouble picking up the default value in the text input field too. If it could pick that properly, maybe this workaround could work perfectly.

Final update

I found a better solution than the above workaround. This eliminates the need for having an input field altogether, and works 100% of the time, even after pressing F5 on a page. So what I noticed is that running any action triggers the filter to ‘readjust’ and work properly. So I just added a ‘blank’ action in the screen’s properties (e.g. Share action without the URL, or “Change input value” but keep the fields empty), and this triggers the filter to run correctly. It does add a jarring stutter every time I transition back and forth the page though :frowning: I was using float left/right, but now I’ve disabled them. I’m OK with this compromise since animations aren’t that common in web apps anyway


I think it would be best if one of the Adaloans could also note this bug and workaround for future reference :slight_smile: @KatelynCampbell @David


Voted. Thank you for figuring this out.

1 Like

hey @AddyEdwin, thanks for noting this! Creating a bug ticket for this is definitely the best way to go — so thanks for doing that :slight_smile: Also many thanks for continuing to troubleshoot & come up with some workarounds while we work out the kinks.

1 Like

Thanks @AddyEdwin for posting the workaround. It helped me in unblocking one flow.

1 Like

Arf, spent hours to try to figure out why I wasn’t able to filter my airtable table using the current logged in user’s email !

VOTED ! Please fix it :slight_smile:

No, it doesn’t help in resolving my issue. I have tried setting a blank action in both the blank screen and the screen where I do want to display the list, and the filtered API request does not returned anything - it’s even endlessly searching…

In AirTable, I simply want to query a table with first column = “BUSINESS_USERS” . Soin the custom list, I have set the query parameter to “filterByFormula”, with value : {{BUSINESS_USERS} = ‘’ }

But it does not work … :pensive:

Can you share a screenshot of the filterByFormula area?

Yes sure, see below (and the slack link : Workspace Deleted | Slack)