Record will not delete

I’m not sure if this is a bug or not, but I’m trying to delete a record but the system will not actually delete it.

image

I have tried to accomplish this a couple different ways. I’ve attached the “Delete” command to the list and I also tried attaching it to the button that is inside the list.

When I attach it to the button, it quickly goes back to the main screen but doesn’t actually delete.

When I attach it to the list it freezes with a loading screen.

image

There seems to be no problem currently with the ADD feature. Just the REMOVE button.

Any idea what I need to do?

I think the problem here lies with the way we are handling dates and there is a mismatch happening with the filter you have set up on that. It is returning no results and therefore has nothing to delete.

I will have to pass this on to the team to investigate further.

In this situation, I have the button set to Invisible if there is no result.

The button is populating so it is finding a result. However, it won’t delete it.

From what I can tell, they have partially fixed the date problem from before. The dates are currently recording correctly in the database (at least visually). But I think there are still issues when trying to set any rules against the date.
I’m not sure if this is related or not.

There were a few issues surrounding this fixed recently on our side. Are you still experiencing a problem here @Michael?

Yeah, I’m still experiencing this problem. I actually sent an email to Ashley yesterday detailing three issues (including this one) that I’m having surrounding this. I can send them to you as well if that is helpful.

I would really appreciate help on this.

I will speak to Ashley directly about it and we will work towards the solution together :slight_smile:

Thanks Colin.
If you could update me with a timeline I would really appreciate it.

My app is stuck until I can get past this issue.
I know you guys have a lot on your plate.

1 Like

Hey @Colin,

Just thought I’d let you know the main issue I’m seeing with the “Dates” now.

It seems like you can make rules using “Date” and “Current time”
But you can’t make a rule using “Date” and “1 day ago”

If you need more explanation, just let me know.

Hey @Colin,

Just following up here. I’m not sure if you guys made any changes or not, but I was able to get the dates to delete. However there still seems to be one issue.

For some reason, it doesn’t seem like I can perform a task after I delete a record.
Basically what’s happening is that it

  1. Performs the initial “update” task
  2. Then it deletes the record
  3. [It fails to] Link back to the previous screen

When I had the Update task after the Delete task, it would also fail to update.

Is this a bug? If not, is there a way around it?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.