Shape as container, with child list of items make Designer crash

I am refactoring my app after migrating it from Legacy Designer - so far all the components’ layout seems to work as expected, but I have a big issue in one of the screens where I have a rather simple structure:

Rectangle (as container) with two child elements:

  • a List of TextFields
  • an icon (link)


Initially, everything looks fine, I can modify it, drag it move it, resize it, etc.
After I played the preview of the app (either from the smartphone or from the Designer top menu) and went back to the designer, as soon as I try to edit this component, the designer UI suddenly freezes and after a few seconds…

making this component essentially untouchable.

I noticed that the issues starts when I add the list into the rectangle and I connect it to the DB…

Is anyone else experiencing this issue?
Any suggestions/solutions?

Thanks in advance,

I am constantly experiencing this issue on all screens where I use a list in combination with other components (i.e. rectangles as containers or groups).
Even when I try to delete the screen completely and rebuild it from scratch, at some point this issue starts to happen and I am stuck on that screen.

Tried also using the browser in Incognito mode after clearing the cache and history, with no luck.
This starts becoming a stopper for the ResponsiveApp designer.

Anyone else having this issue?
Thanks in advance

Hi @enricomilani,

Tried to replicate this - I don’t see the same issue… Here is my sample screen:

I’m using latest Chrome (114) on MacOS Ventura 13.4.

Did you try using other browser?

Best regards, Victor.

Hi @Victor
Yes, of course, I tried both Chrome and Edge with the same results. But concerning your essay, I have some doubts:

  1. you’re on a web application, I am on a mobile app, migrated from Legacy designer.
  2. how did you set the “Layout properties” of these objects? I noticed that if you limit the visibility to mobile only, the defect is worse - but allowing all platform is not a solution anyway.
  3. is your list connected to a DB or just defined it as a list? It makes a lot of difference in the behavior.
  4. Your screen seems not to be connected to any other.

The issue, as I tried to explain, is not to be able to create it, but to be able to edit it after you’ve created it and previewed it at least once.


Hi @enricomilani,

  1. Yes, this is a Adalo 2.0 app created from scratch. Let me check this in the migrated one.
  2. I didn’t set any layout properties for these objects - I use the default ones. Did you set any specific properties?
  3. Yes the list is connected to the DB.
  4. Do you experience the issue only when the screen is connected to other screens? I assume that this shouldn’t be the case based on your description?
  5. Of course I’ve launched the app in the previewer as this was in your post. And yes I am able to edit it after previewer.


Hi @Victor thanks for the reply :slight_smile:

2.Initially I was setting all the items as visible only on mobile, as my target is only mobile native app, but this seems to worsen the situation and so I got back in leaving essentially everything to default., it happens also on stand-alone screens with no connections - I asked just to have a clearer understanding of your test.

I can share a preview of the app if you would have a look into it


@enricomilani ok, here is the experiment which I just did:

  1. Created a fresh Legacy Mobile app. Here is the screenshot:

Obviously, everything works just fine.

  1. Made a copy of the Legacy Mobile app as Responsive app. Here is how it looks right after cloning:

  2. I’ve rearranged the items in the mobile app so that they are “inside” the rectangle (moved them away and back in). Now it looks like this:

I tried also to change the layouts (hide/show elements), move elements, etc. Still wasn’t able to reproduce the issue you have :frowning:
As I’m still on a legacy plan I wasn’t able to publish the app - the only thing which I couldn’t test.

It might be something specific related to your app copy - so it might be better to submit a support ticket: Submit a Support Ticket. Maybe someone else will also chime in and share their experience.


Hi @Victor I already submitted a support ticket.

Thanks anyway for your support


1 Like

@Victor As an update:
if I remove the LIST from the screen, keeping the objects, the issue disappears… :face_with_head_bandage:

I will do some more research on this side… but I don’t understand why on all the other screens this issue is not present


Hey @enricomilani,

Interesting. Is it just this one screen with this list? Or all screens with a list have an issue?


@Victor I have many lists on several screens across the app, but only this screen is causing those issues.

I was finally able to solve this annoying issue that blocked me for days…
In one screen (the “hover” I used in this post) I had to delete completely the screen and recreate it using the “modal” template, then removed the template’s object I don’t need and added the list and the text fields - I guess the conversion from the legacy designer to the responsive app one brought some properties or attributes not compatible…

In the other screen, the more complex one with a list including text, image, title, etc, I noticed that this new designer is more fragile handling overlapping components (I had the top header and the main list overlapping by 8 pixels).
I had to redesing the screen using the list as main container, in which I then added the image, the top header, the hovering icons, etc…



Note: It appears that layout properties in the case of grouped items work well when inherited from the parent, while I had some strange behavior trying to set a child element with specific properties… Need to look deeper into this, but at least I’ve been able to overcome the blocker.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.