with Google not linking to next screen

I use the “Sign-in with Google” component on my app. It works on PWA; however, it is not working on the native app after downloading from Play Store.

When I click Login or Sign-up, it finds my gmail addresses, but after picking either of them, it does not link to the next screen. It seems to just get stuck on the Login screen. When I login with just the Adalo email/password option on native, it let’s me into my app. On PWA, both email and Google login work.

Is / has anyone else experienced this?

It’s similar to the issue linked below; however, in my case, waiting or trying again does not help. It’s been doing this for hours now.

1 Like

My app did the same thing. I couldn’t fix it and eventually just took it off. They told me it worked for them. I tried it on several devices and had 50 emails about people not being able to login. So I took it off.

Yeah, this is extremely frustrating. I checked the entire setup and don’t see anything wrong with it. I also tested Sign-in with Apple on native, and that worked. This appears to just be an issue with the Sign-in with Google on native.

I’m making some app updates and want to see if the next build will also have this same problem with Google sign on.

New build didn’t fix the issue. Sent in a support ticket but also wanted to reach out on the forum in case anyone has any suggestions.

We’ve had the same issue with our app. Exact same. Double checked the Oauth and everything. Unable to get approved by Apple because Apple ID isn’t working. (Google also isn’t working unless on PWA). Does it maybe have to do with the domains that are allowed to redirect? The instructions have us add the testing domain from Adalo, however when using native apps it shouldn’t be redirecting from the test domain, so perhaps that is the issue?

1 Like

This is a big problem. Does the Adalo team check this forum? I’m new here.


I don’t think this is the issue. Adalo domain should be listed for the previewer to work. Credentials are setup specially for Apple and Google separately, so I don’t think its the domains.

Have a support ticket still outstanding, so I’ll update the post when I have more info.

any update on this problem? It’s been so frustrating I starting building my app from scratch.

I recieved an email Tuesday, so that it should be fixed. I haven’t been able to check though due to work. :frowning:
I’ll check when I push my next build this weekend, and let you know.

Well I started my build at 4am (6 hours ago) for Android to see if it fixed it and it’s still in Queue. if it ever processes, I’ll let you know.

Was finally able to test a new build, and it still doesn’t work…

Please Submit a Support Ticket so we can help you better through this issue.

I submitted a support ticket on 12/28. I replied to that email last night around the same time I wrote this reply.

I need to submit another support ticket?

This is not a new issue. I’ve already sent a video and screenshots of the firebase setup.

This just feels like the run around at this point.

1 Like

Thanks Mate, I saw now you asked before :raised_hand:

Hi guys!

I just made it working.

The problem is:
In many cases we are adding login action and then link action to Init screen, we have to rremove the login action, this needs to be just when email and password flow.

Also remember to put the apple sign in… it will be required in Ios(this is another thing they are warning and its not related to this).

I also had to do the same for the apple sign in

happy you were able to get it to work! I’m not using the login action or any other additional actions. Just linking to the next screen. Apple is also connected.

Deleted component and re-added it yesterday. Just tried a new build after seeing your message to see if any backend updates fixed the issue. No luck. Still doesn’t work, and no support update from Adalo whatsoever.

We are investigating this new issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.