Technical Issues (Lag, Unresponsive, Cannot Preview)

Hi everyone,

I’m experiencing some technical issues with Adalo. It was working well earlier today without any errors or lagging, but now when I use Adalo, it is extremely slow and laggy, and takes a few seconds to respond. Additionally, when I try to preview my app on my phone, this message pops up:

I’ve tried working on a desktop computer but Adalo is just as slow as it is on my laptop. And I’ve tried removing and then re-adding my app’s bookmark on my phone but the above error persists.

I don’t understand why this is happening; my app currently consists of one data record and it only has five screens, most of which are basically blank.

Is there a fix for this? Is anyone else experiencing these issues?

Adalo seems to be working ok for me… so it could just be a network connection issue in your area at the time?

If you can retry from a different network (ie a different Wifi/Router, or from cell phone connection).

Thanks for your response @TonyD! I tried previewing my app from my phone with WiFi turned off last night and no error message popped up, but today when I tried I got the error message. I also restarted my router, but Adalo is still laggy and slow.

Hi @bobsunscreen, sorry for not getting tot his sooner. Are you still experiencing issues with this?

Hi @colin, no worries. I noticed that if you use large, high-resolution images, it significantly slows down Adalo - so I have lowered the quality of all the images I use in my project. That initially fixed the lagging problem for a week, although now it appears to be back. With regard to previewing my app, that is no longer a problem.

UPDATE (9 hours later) - My project is no longer lagging.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.