Updating Collection results in a new record :(

Hiya @dilon_perera , in the above thread you helped @Henrikcox figure this out, and was wondering if my situation is similar… I as well am working collection that has a many-to-many relationship between ‘Users’ and ‘Teams.’ As a Team MAnager I’m trying to add a new player and then update that player to be on my specific team. I’ve tried both Add New Member or Current and it simply creates a new blank record in the Team Collection… I had it working prior but now it’s driving me nuts and I can’t figure out why… any ideas? Would greatly appreciate it.


Hi @tbel,

You have to add New Member. Did you tried deleting the Update action and adding it again?

Thank you

Thx Dilon, at least I know now New Member is correct, but yeah it must be something else, I did delete the update action, I even went as far as creating a new team, but still does it. I’ll try to get more information. But this page does have access to the correct data

Question: Why are you creating a new member when the screen already contains a current member?

Great question, I initially had "Current’ but why would Adalo ask if you want to add a New member just after creating one? Confuses me a bit

Can you provide a screen recording that displays your screens, lists that lead to the current screen, on-screen actions, and the actions to create member/update team?

You can use Loom to record your screen for free.

The mixup here is that you shouldn’t have both “Current Member” and “New Member” as options to select. So we have to figure out where you’ve linked the current member before creating the new one.

1 Like

Hmm, ok I don’t have much time left to play with it this morning, but I’ll quickly show the loop

As mentioned it worked amazingly well before, but I must’ve deleted a link or something that threw it all out of whack :frowning:

A screen recording would have been more helpful as I can’t tell which list is nested. I don’t understand why you have a nested list here either.

Based on what I’m seeing, you have a link that goes to your “Add new player” screen which contains a current member. Find that link and delete it.

Then, switch the “Update Team” action where you have add team members > add current member to add team members > add new member

1 Like

Ok Ill do a couple today… but thx for this info, I’ll investigate that.


1 Like

Oh man that did it! I had a link sending the current member data to that screen, removed it and it works! Help me understand haha, was it getting confused with current/new and just bailed hence creating a new record? thank you so much! :pray:

1 Like

@Flawless you are the man! Thanks for your help here!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.