URGENT!.. File picker not working

Has anyone had an issue with the file picker component today?
file picker component when clicked there is no response. The pop up dialog for select files does not appear. I’ve tried using several different browsers and Adalo accounts.

I have informed this by submitting a ticket to Adalo. just wondering if any of you have experienced the same thing?

Ya same we are also facing the same issue file picker component is not working.please fix this issue

Hi @Colin @Ben … Can you explain, is this a client side problem or a platform (adalo) side problem?
or this issue is related to a problem solving that I made a thread in this forum:
https://forum.adalo.com/t/adalo-security-storage-url-link/9760/4 → already submitting a ticket too

I faced the issue today too. Simply click and doesnt load to pick the file. Had to do a workaround.

hi Ron,

have you got an alternative solution for this case?
adalo has replied to my ticket and is in the process of being repaired. but currently my project is live and quite a lot depends on the file picker component, so I have to find a quick solution.

tried using an input form component with the property type files. but apparently it doesn’t work either

Hi @oktovan can you share with me your live app so that i can take a look and advise? I solved it with my files type that i was uploading. So i skipped the file picker until it is fixed.

I have idea that if you temporary use the profile image file picker under user, it may be a short work around. But maybe share with me your app, see what i can do to help.

I just deployed my first iOS app from Adalo last night and the file pickers are crashing the app. Could this be related?

Hi @ron … for user skipping upload file is not an option… because that mandatory task for every user.
yes you right, using image picker or form input image type is still works… i just check that image picker can be use for non-image files type too… but i need a screen handler when non image than will show some icon. if not, than it will shows black on the picker container.

Sorry i cannot share the apps, because this is for my company internal web apps and already have a live data.

anyway thanks for your great idea… i hope adalo will fix this problem soon…

1 Like

Hi, @oktovan @Colin yesterday we have built an android app in that the image picker is not working properly, which leads to crashing the app.

Have you reported this as an issue to reflect on Adalo’s Status page?

Already we have reported this issue yesterday.

Hi @senthilmanikandan and @ianstorrar … i’m not sure for your situation… what i experienced happens when using web apps… This doesn’t crash the web app, it’s just that the pop up dialog that should appear when clicking the file picker doesn’t show…

With so many people reporting this issue, I hope Adalo can immediately fix this situation

2 Likes

The developers will be looking into this one today.

2 Likes

Hi @Colin … the file picker component is confirm already fixed for web app and PWA. If you are using this in a native build anywhere, you will need to publish a new build for the fix to be in place.

thanks to adalo teams… :ok_hand:

3 Likes

thanks to Adalo team for fixing the bug issue.

1 Like

Hey all, is this resolved? File Picker is crashing my Android App?

Also is there a file upload size on Adalo File Picker? @Colin? I ask because I am uploading files to AWS S3 and if they are a certain size they simply do not load in Filer picker therefore not giving me access to the File URL to transfer to AWS. Any ideas?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.