Use dropdown to filter actions?

I have an event app and in the first page I let the user pick what types of events they want to see, I am looking for a way to set an action that will bring the user to a different page depending on the type of event they choose, any ideas ?

Hi @gabs,

You can make link actions conditional (happen sometimes) depending on the chosen action type in the dropdown. Just type in the value which you are comparing to.

Best regards, Victor.

I thought that would work but when I tried it didn’t but I might have done something wrong.

  • created a collection called events and added a record for each event category
  • I added the action link to a button element, set it up to happens sometimes
  • the conditional was the following: "if dropdown element value is equal to “entered manually the name of the event category present in the database” then link to page “x”

Can you tell by any chance where the error might be ?

Hi @gabs,

Hmm, just checked it in the test app - doesn’t work for me as well. What I see is that it’s not possible to choose Selected Event Type → Name for some reason… but as I remember that worked before (??).

Anyway there is a couple of workarounds.

If you don’t have a lot of event types, you can create several buttons (one for each event type) and make them conditionally visible based on the value of the dropdown (this works).

Another option is to add a property to Users collection (e.g. Selected Event Type Name). Then a first action on the button will be to update Logged-In User → Selected Event Type Name to Dropdown → Selected Event Type → Name.
And subsequent actions will be conditional, but condition will depend on Logged-in Use → Selected Event Type Name.


Thanks a lot mate, I really appreciated

Not sure if you have the time but if you could also help me with this other problem it would great, I have been trying to solve it for the past 10+ days.
Basically the markers of the map element keeps flickering around rather than be fixed in their position, the issue only appears on Android (iOS works fine). Do you have any idea what could be the reason for that ? Any ideas or hint are really appreciated :pray:

I’m not sure I can help here as some debug of the actual app might be required. I’d suggest you submit a support ticket for this issue.


Yeah I tried but they said they don’t have time to look into it

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.