User exists- Not able to sign-up

Hello Wonderful Adalo community,
Issue with Sign-Up, error that user exists, even though user is not in user records. I have tried removing all users, it worked for first user sigu-up but for second same issue occurs. Can someone please help.


Hi @Gunjan,

In 99% cases this is related to some mess in Users collection’s properties or in the Login/Signup form (leave 1% for Adalo glitches).
How your Users collection is structured? How did you set up your Sign Up form?
As a test - what if you add a new temporary screen, add a sign-up form there, set it up (with email and password) - do you see the same effect?

Best regards, Victor.

Hi Victor,

I’m having the same issue. My form only requests Name, Email and Password.

What kind of “mess” in the properties are you referring to?


Hi @afonso,

There are 4 built-in properties in Users collection: Email, Password, Username and Full Name. They can’t be deleted by design.
The only property which is checked for uniqueness is Email, meaning that if one tries to create a user with the same value in Email field, this will fail. Just in case, adding a space before/after isn’t checked, which creates another potential headache for support :wink:

However (and unfortunately in my point of view) these properties could be (a) renamed and (b) rearranged together with other custom-created properties. I’ve seen that quite a lot of times.

The issue is, that if app Maker renames “Email” property to something else (e.g. phone), and renames other “built-in” properties, it will be quite difficult to find which exact property is that “built-in email” which is checked for uniqueness. Especially if Maker decided to create another property and name it “Email”.
The only hint is that built-in properties couldn’t be deleted (you see the lock on the right side). At the same time any first property in the collection couldn’t be deleted, which adds some intrigue when you try to find the original email property.

So imagine Users collection with 20+ various properties, original properties rearranged and renamed, and you are creating the form to log in / sign up a user. This is what I call a “mess” :slight_smile:.

If you’re 100% sure you don’t have such case and you’ve set up your sign-up form correctly - inspecting browser error console can give a hint about the error’s reason. Sometimes Adalo DB has glitches.

Hope this helps :slight_smile:

Best regards, Victor.


Thanks Victor! Much appreciated.

1 Like

Thanks Victor! My issue seem to be related to no. of records. I reached max-limit 200 records, once I deleted some then this issue was gone.


@Gunjan thanks for following up.
So it seems Adalo doesn’t handle the error message correctly :-/


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.