Video uploads from camera roll | Not working

Hey guys.

Interesting bug popped up for me the past couple weeks. For anyone with apps utilizing user generated video content, my latest builds are unable to pull in videos from the camera roll. You tap the video but nothing happens. Image uploads from the camera roil work just fine. You have to do it in TestFlight to replicate.

Unfortunately, this is a huge issue and is holding up a major release on my end. Jessi and the team are aware of the bug, have been able to replicate it and are looking into it, but wondering if anyone else is experiencing the same thing. May not be something people are testing since it has always just worked. If others are having the same issue, might help to bump the urgency on this one.

Alright guys. Might need some help here. Adalo has confirmed that user uploading of videos on iOS using the file picker is broken and there is no plan to fix. I am sure this affects many of you. Please test your apps and submit tickets to reflect the issue of it’s happening.

Otherwise, anyone have workarounds for video upload components? @Victor @Flawless @theadaloguy @Michael thoughts on solutions? Trying to avoid external storage solutions. Appreciate you guys and hoping you can help. Without this working my ability to push some major updates and bug fixes eliminated.

1 Like

It’s when you go to take a video that it crashes? But you can select a video from gallery ok?

Can’t select videos from your camera roll. So frustrating. Images can be selected just fine. No crash just nothing happens. They confirmed the bug.

Ok but it lets you take videos no problem?

Just taking videos with the phone camera is fine. Not doing that through the app. Trying to load directly from camera roll previously loaded videos.

Adalify file uploader can upload from gallery if you want to try it. There’s 2 week free trial when you sign up. I have also noticed issues with taking videos which is why i was asking.

Might have to give it a shot. I know we chatted about it before. Will I have to restructure database side of it? Pretty amazing how many people probably rely on video uploads right now and don’t realize it’s busted.

Yes you’ll reference the video url rather than the video being stored on Adalo. The video will be on Amazon S3, and you have a database field on Adalo with the url.

Ok. I’ll have to do this. Should streamline upload process as well. You think more file formats will work with adalify vs adalo? That’s been brutal for me as well.

It is faster upload, and should work with most file formats. Also can upload larger files no problem.

Last question. Sorry. I can keep the plyr component in place to play videos right, just change the source location?

Yes exactly, you’ll be using PLYR component

Hi @jromeo80,

Sorry to hear that such a bug doesn’t have any timeline to be fixed :frowning:

Just to clarify - is the issue with Image picker or with File picker?

Best regards, Victor.

Thanks Victor.

It’s the file picker. Didn’t think the image picker let you grab videos, but maybe I just didn’t notice that option…been a while since I messed with these components since they have always just worked.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.