Another bug. What to do

Morning community! Recently, I’ve been really deep into the development of my app and it’s been good! I’ve got the first few versions on the App Store and Google Play Stores, and people are really liking it so far. I’ve got a few feedback suggestions that I’m working on, and, since I’ve been doing so much work on it recently, I’ve hit a few snags with a couple of bugs. When I do, I put in a support ticket each time. Today I’ve encountered a bug that is not allowing one of my groups to message each other. Every other group works and it’s the same screen, just different data that is linked to it per group (users, current group, etc). I really hate to submit another ticket because at this point I bet they hate seeing my name pop up on the ticket requests :joy::joy:. I feel like I need to grow in my ability to debug some of these situations myself, when possible. Does anyone have any steps that they can suggest for me as I try to do this?

:sweat_smile: :sweat_smile: Maybe try it the engineering way, switch it off then on!

By this, I mean delete the group and then try to upload it all over

Not being rude here, but this isn’t an Adalo bug, it’s a bug you created. Adalo support isn’t exactly designed to help for solving issues you create in the app. I’d say it’s more for solving platform issues.

Going forward, it’s best to provide as much detail as possible in your post so the forum can help you solve it and people can see how it was solved in the future (on that note have you searched the forum for previous posts about this issue?).

I can’t help answer your question with the limited information provided.

Haha, you’re right @Jeorge maybe that’ll give it the kick it needs.

@Erik thanks for the feedback, but, to be honest, I’m not sure that I agree. I’ve received responses before from adalo support tickets that said “we know it’s a bug, but it’s not a priority right now.” So, it’s hard to know what is a fault of mine and what is a fault of the adalo software. The issue I’m facing is fairly straightforward… create a group, and then message in that group. It’s all created the same way and on the same screens, but it’s not working with one of the groups. It’s working on all the others. I’m not sure if it’s another bug that they’re aware of or if it’s my fault. It’s hard to tell at this point.

The reason that I posted this in the forum was to see if anyone could suggest some simple troubleshooting tips so that I can try those out instead of submitting multiple tickets.

1 Like

Can you share more details on the issue though so we can help? It would be good to create a loom video and walk through the DB setup and the how the groups work. For instance maybe messages aren’t being filtered properly or there’s an action missing adding the relevant users to the group etc, but impossible for us to help without the details.

For troubleshooting, what I’d recommend is:

  1. double check your database collections and make sure the relationships are correct
  2. double check your actions and make sure they’re firing and working properly
  3. Check list filtering
  4. make a detailed video and post for the forum!

It’s pretty rare that we ever fill out a bug form and we do quite a bit of apps. About 30-50% of our bug forms end up being an error on our side… and we’re adalo experts… just an fyi.

@Jeorge I got the same advice from Adalo support - seems like there’s an issue when you try to copy and past items that have data linked to them across the app. I rebuilt the “go to message screen” button for the group and it fixed it!

That’s great, sad though that we have bugs

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.