Can't seem to get image upload to work

I’m brand new to Adalo. I’ve created a progressive web app, haven’t published to stores yet.
I’ve created an image picker and called it Image Picker at the Top

I created a form that is supposed to pass in a field Image in the Documents table.

When selecting the image on the phone or computer or taking the image on the phone, the image shows fine on the image picker. The Document in the Documents table gets created fine.
However, there is always no image in the Documents table - it’s just blank.
Not sure if I’m missing something?

Updated - I also tried the Modal approach without success:

Two things

  1. I tried setting a condition on the OK button to only link back if the image picker is not empty, and it doesn’t link back even if I upload an image. This might be a clue
  2. The image in the database is always empty.

Uploading an image using the Image form field works, but that field is not customizable, and is super ugly. Uploading an image using the image picker field doesn’t work.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.