Custom Domain/DNS Issue

Hello, I have the same issue, the one that chadblumenthal mentioned. I use Google Domains and tried lots of stuff mentioned here in forums but cannot setup my domain, it even appears an error now when I try to enter:
I send screenshots:

for what i can see your adalo app domain is and not

go to your app on adalo → settings → domains
and click the “reload” botton that will reset your SSL.

And wait 30 M

Hope it helps.

Thank you Alfonso! The thing is, my original domain is, I typed app before the domain because I saw it in the comments, but I would like to use the original domain. When I try to follow Adalo´s instructions, this happens (it says I cannot add a register to the root domain):

ok, i also never been able to register a root domain, so i also use the

Hope some one knows how to do it.

Let´s hope some good samaritan answers :slight_smile:

Have you tried using www as your NAME field?

NAME: www
Points to:

That should do the trick.

Thank you charleshope, but since I made changes all that happes is this: DNS_PROBE_FINISHED_NXDOMAIN

Now I cannot even see the webpage :confused:

Also I added the www