Empty State Not Working

Hi! I’m following the instructions for creating an empty state, but it doesn’t seem to be working. Are there situations when an empty state doesn’t work?

Here’s my current set up for the empty state image:

Along with the list itself:

Looks like there might be a couple of things here:

  1. You don’t need to add visibility conditions to your list. Nothing will show if there are no list items
  2. It looks like your list and your empty state image might be occupying the same space on your screen. Instead have the image be below the list.

Thanks for the quick response! I implemented both recommendations, but still isn’t appearing.

When I load the preview, I do see a blue wheel that seems to suggest the list is attempting to load, but as shown above it ends up blank. I’m also not able to scroll on the preview screen.

I’m having a similar issue. The empty state image appears for a second, and then the list appear when a screen is loading. The image is below the list as recommend. Both elements has the same but opposite visibility filters. The list loads after the image and we want to avoid this behavior. Basically the system should verify first the global visibility conditions and after that show the right elements on screen. This could be fixed from my side?

Have you attempted ‘less than 1’ as conditional?

You may also want to make it ‘equal to empty’.

Thanks Greg! problem solved!

1 Like

The “less than 1 as conditional” solution works for me. Also you need to use an image and avoid using a group (e.g. an image and text)

False alarm. I tried the different recommendations without results. Any other recommendation? I tried to reorder components in the left panel. The list database has only 4-5 entries. I do not stablished any visibility condition for the list as Ben recommended.

Have you deleted one list for example and then recreated it again? (make sure they aren’t overlapping. I’ve had an issue where I thought the conditionals were different and they were being grouped together. Look into layers and double check).

I’m also having this issue, anyone find a fix for it yet or figure out what the issue was?

I think the problem here is, when a list is empty, the count is null. That is why if the condition is count is equal to empty, it is working. But when the count becomes 0, empty is not equal to 0 and the condition is not met. I don’t know a workaround to this yet, the less than condition does not work too.

I think I found the solution here, and ever since I did this it started working for me.

When you are setting the visibility, it seems that the editor saves the conditions that we set even if we do not click the “Done” button. However, I think it is not applied unless we click the done button even though it saves the conditions that we set.