Google authorization. Error 400

Google authorization does not work, I can’t understand what’s wrong, please help me.
OAuth 2.0 Client IDs made, Web client ID added.

Please, help me understand what needs to be done.
For me, this is the final stage before uploading the application to the store.

  1. I created my Android Client ID
    like in Adalo tutorial

  1. Then I paste it in Web client ID for button “Google Sign in”
    like in this Adalo video tutorial:
    New Component | Sign-In With Google - YouTube

After that I’ve got error 400:

BUT in tutorial on Adalo website there are said:
7. After that click create. Note that you won’t need to paste this into Adalo, you just have to have it created for your Google Sign In to work on Android

If I do the same, in preview my button looks like


What to do? Help me please.

Hi @Ossa,

It seems you’ve set up your Google console credentials incorrectly for Web authentication.

Googling ( :slight_smile: ) the error from your screenshot shows some results saying that this might be caused by incorrect OAuth 2.0 Client ID type.
As I see, you have created type “Android”. Checking my Google Console - I have it for type “Web Application”.

This corresponds to section 4 of the instruction here: Sign in with Google - Adalo Resources (which is called “Create your Web Client ID”). I don’t see it on your screenshot.

Best regards, Victor.

1 Like

Hi, Victor

For some reason I decided that this item is only for the web version because in my case it only a mobile application, so I skipped it.
Thanks Victor, I’ll try.)

Victor, thank you very much! I really missed point 4.
Everything worked out! I wish you success

1 Like

Well, again …
Everything worked in PWA, but after publishing, “Google sign in” does not work on phone.
Does anyone have any thoughts on how to fix it?

The same problem was in this theme, but no solution

Please tell me how to fix it?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.