Notifications IOS not working

Hello, I have a app build in TestFlight currently but the TRIGGER notification does nothing. The app does not receive any notifications. When I first start app, app ask for allow notiifactions but still, nothing get delivered to app?? Is that a known bug? I have read its not the first time that they don’t work.

I placed a button with function trigger notification all users. when I press it nothing happens, it should fire notification at all apps in TestFlight or?

1 Like

I saw others with push notification problems. Is it a adalo problen? When its fixed permanently? I need reliable push notifications in my app :confused: @Colin

Hoe can adalo push work without APNS SSL Certificate??

1 Like

Hi

Did you have the user accept notifications during sign up?

Make sure when you’re signing up, you receive the request on your iOS device to push notifications. If that request doesn’t come across you can try to double check if you’ve already granted notification permission in your settings.

There are strange cases where notifications won’t trigger. If you’ve requested permission, granted it, and the notifications aren’t triggering, I’d submit a bug ticket.

Hello Erik I double checked all and everything is in place as well as the Request Notification Permission. Ok I will file a bug report for my app. Thank you.

Hi @pushingpandas,

I’ve been playing a lot with Push notifications this morning - for me everything worked in my test app.
The thing I’ve noticed during the experiments - you can’t send the notifications to yourself. Here are the cases:
First case:

  • User A is logged-in to the “Admin” app (the webapp I’ve built to manage notifications).
    User B is logged-in to “Client” native app on the phone.
    When User A sends a push notification from Admin interface, user B receives it. In my setup the notification is sent to group of users or “All” users.

Second case:

  • User A is logged-in to the “Admin” app.
    User A (same user) is logged-in to “Client” native app on the phone.
    When User A sends the notification (to a group of users or to All), nothing is received on the mobile.

I can guess that it could be the restriction of the API, but the clarification is needed from someone from Adalo who knows it better.

Best regards, Victor.

1 Like

Hello Victor, thank you. I used your awesome tutorial regarding Scheduling Notification and it did not work for me. I will try again with complete different iPhone / Account setting.

I tried the button for debugging. Colin answered my email with “Looking at that button, you have set the trigger to send to all users. This is not possible as the notification needs to be associated with a single record of that user’s email address.”

So the ALL USERS is not possible if its only working with a single record of the user. How to send mass notification to a couple of people? e.g. your schedules tutorial.

1 Like

Hi @pushingpandas,

Well there are options available in the app builder:

  • send notifications to “All” users
  • send notifications to a group of users. You need to create the appropriate relationships first.

Best regards, Victor.

I try again with completely different accounts. I report back.

Hi, Victor, I’m also facing problems with notifications, and I’m trying to solve it on Android, I haven’t even tried it on IOS yet. Do you mind sharing your test project? I believe that everything should work on it because you should always be using the best practices. Thanks.

Ok the notification working now on IOS. I need to use a different account. But on ANDROID Notification are not working. Do they usually work in internal testing?

Ok Now they working on android too. Thanks :slight_smile: Case closed :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.