(Some) Properties Not Present in Downloaded File


I downloaded my “Visit” collection file to conduct analysis and noticed some of my relationship properties are present while others are not. Any idea why this is happening?
See below for the missing properties:
The “Scheduled notification” relationship property - a scheduled notification is created when a user visits a location
The “See more categories” relationship property are derived from a multi-select component - user select multiple options from a collections list

Hi Emeka,

Try expanding the size of the column. Sounds kinda crazy but has worked for me. It seems like CSVs actually borrow the length.

@barrettnash unfortunately that didn’t work as the properties I mentioned don’t show up at all when I download the file. As in, their columns aren’t present, header or underlying data

For collections that contain the “many-to-one” or “many-to-many” relationship parameters, Adalo does not load the relationships in the CSV.

Only collections that have the “one-to-many” relationships will contain the relationships’ parameters.

Let me show you an example:


Thanks Flawless. Is there a rationale for this?

Oh and I’m realizing I need the “many to many” relationship in order to use the “multi-select dropdown” component so I just have to find a workaround

The short answer: One-to-many relationships own the data. Many-to-many relationships both collections own the data.

Long answer:
Importing a CSV into one collection cannot update 2 collections at the same time.

Since a CSV import can only update one collection, it can’t update the relationship collection.

In one-to-many situations, the relationship parameter belongs to the “one” side, not the “many” side.

Whereas in a many-to-many situation, the relationship parameter belongs to both collections and requires both collections to be updated at the same time.

Additionally, “Many” relationships need a way to be separated in a CSV that isn’t commas. So coming up with the best route to manage how the CSV would handle multiple records in 1 column wouldn’t necessarily be easy.

Commas within a field will break a CSV import. So we can’t have a field separated by commas within a comma-separated-value sheet.**



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.