User email already exists?

It seems as this had been discussed in the past, but there was never a concrete answer. I am having a very bizarre issue while signing up new users to my app. The user database is empty, however, when trying to sign up, I get:

I am using a custom domain and that’s not exactly the issue since I am able to get to the page and login to my apps. The problem however goes away if I don’t use the custom domain and use the app.adalo.com link. It also works fine during the preview. This makes me think the issue is on the backend and how adalo handles the user creation AND password recovery when a custom domain is being used.

I already checked my DNS records and even tried with an ntirety different domain and company (GoDaddy and Hostinger). The issue still happens in both domains.

I also tried to clone the app, remade the sign up screen from scratch, but no luck…

I already submitted a ticket, but unfortunately no response yet. Looking forward to hearing any new suggestions.

Hi @Cahg9,

Welcome to the community :partying_face:

Is it possible to share your app URL to test this? And are you on the free plan?

Thank you

Hi Dilon,

Sure! It’s Store

The preview url (which does work) is: Store

I’m on starter plan. Publishing to the custom domain is working. Once I manually create a user on the database, I can use the app from the external site and works as intended on all other functionality, except sign up and password recovery screens shows the error. Password recovery never actually sends out an email even if the user was created manually and in the database.

Andres, could you share the actions attached to the sign-up button?

Here it is: