Web App Not Saving

Hey there,

When I make changes to my web app, they do not save if I refresh the screen or view my app in the preview. Is anybody else having this problem? I am not sure if there is a manual save button somewhere but I am unable to find it.

Thank you for the help,


I’m having the same issues. I haven’t been able to save any recent changes along with shifting element problems.

Changes are not saving and building in preview for me either… going on about an hour now. Is there an update from the Adalo team?

I’m having the same issues, I need to work urgently on the platform

Me too, for like the last hour and a half now.

I think whatever happened caused several things to mess up in my app. I have a list that is stuck on screen like a ghost image you can click but when you try to delete it adalo crashes. Rough day, pretty frustrating, hope its fixed soon.

Im having same problems

Same here, lost about 2 hour worth of work when i refreshed the page, thinking that the app has autosaved - really p*ssed off about this & needs addressing urgently.

I couldn’t do anything today Does anyone know if this is still an issue? thanks.please let me know, thanks!!!

It appears it is still an issue. I am sure the team is working on this problem if they are aware of it.

@Ben @jeremy

Hey guys, wanted to bring you into this to inform you of this problem. Any idea what’s going on?

Thanks for the reply Jacob, no worries.

I still got the issue! don’t know when this will be fixed

The same problem here in germany
i dont know whats going on !!
not only the web app, also the mobile app

The same problem, here in USA, what happend?
Any update from Adalo Team? @Ben

I’ve got it too here in Texas. Definitely a system wide issue.

Its working for me now

It worked for a moment, but it still doesn’t work completely.

It’s still saving (if you keep windows open), but it’s very very slow. Good luck (and courage) to the Adalo Team … @Ben

Hey guys. Just wanted to provide an update here. Things were saving very slowly earlier (~10 minute delay). We made a change which will prevent this issue from occurring in the short term, while we put a more permanent change in place.

Also, you may have noticed some slowness in the loading apps lately, and this is related to the issues. We be able to make this quite a bit faster as well with the fixes we’re working on now.



Thank you for the update and for all of the hard work!