Button can't do more than one "Change Input Value"?

Hey Victor,

Thank you so much for this - but I already tried all types of buttons (Action Button, Icon Button, Regular Button), with a weird phenomenon: It works for about 1-2 hours, and then breaks down again. Can you please recheck your clone later today?

Sure, no pb

Hey Victor,

Does the new button work for you still?
Unfortunately, it doesn’t work for me now (tried all 4 button options, including putting it all in the group like Rozza stated).

Any idea of something I can do to solve it?

thank you
Tom

How very frustrating. I will have a look when I have a chance but unlikely to be today.

And I am half the solver that Victor is. But I will try.

Hi @TomBlue,

I guess it’s a issue with the Link Transition!

Check this video! : Change Input Value Action bug on Vimeo

Tom, try making the transition to other transition types instead of None and try!

Thank you

Hi @TomBlue,

This is really strange. The button which I’ve created in the clone of your app stopped working. It started to work again when I changed its settings (transition → none and back to push).

At the same time, the button in my test app (completely separate one) still works fine.

The issue is somehow related to transition: when I changed the transition type to “None” for button, it stops working. However when I change transition to “Push” for Button and Icon, both of them work.
However, in my sample app everything worked fine irrespective of the transition type… and then stopped working for transition “none”.

What I think is that core problem is not related to transition type, but rather is affected by its “speed”; the problem lies somewhere in the way this new “fast loading” thing works (and this has been introduced in instant navigation).
What makes me think so: I have made a sample to update 4 inputs based on the values from the previous screen. So, first 2 inputs are updated, and last 2 are not.
If I’m updating these 4 inputs with static hardcoded values, all 4 are updated.

I may be speculating here, but I think that the reason could be:

  • when the user goes to the next screen, input values on the current one are emptied
  • how it worked before Instant Navigation: upon button press, first values from inputs on the current screen were copied to the inputs on the next screen, then transition was executed (and inputs on the current screen were emptied as a part of it, closer to its finish)
  • how it works now: upon button press, values values from inputs on the current screen are copied at the same time while executing the transition. So, if transition takes “longer” time, more of them are copied before emptying; if transition takes “shorter” time, there is less chance for them to be copied. This is some kind of “race condition”.

Also, based on the info from this thread Is there a way to turn off "Instant Navigation"? - #4 by afonso, I’ve tried to turn off “instant navigation” by adding a “sometimes” condition.
And disabling this instant navigation solved the problem.

Please see the recording here (no sound but everything should be obvious): Loom | Free Screen & Video Recording Software

@Adalo_CXTeam @adalojosh this is a very non-obvious issue which is almost impossible to diagnose being a maker. Such bugs produce a lot of frustration as one can’t really understand what’s happening and what is he doing wrong. Could you please pay attention to it?

Best,
Victor.

3 Likes

Please don’t tag Adalo team members :wink:
Good citizens should raise a ticket at this moment and practise not discussing bugs in public.

Thank you for cooperating.
(Said somebody in 1984)

@victor I have nothing but respect for your abilities. In my own sarcastic way I am championing what an open forum delivers to the community but also to Adalo. For @dilon and yourself have drilled down on this with such detail, long before an ‘intricate ticket handling system’ could have.

Everybody wins in an open environment.

2 Likes

I truly appreciate your assistance, Victor, from the bottom of my heart. I will definitely try the solution you suggested and hopefully, it will solve the issue for good.

1 Like

I disagree, Victor tagging the Adalo staff is a good idea in this situation. If Adalo staff does not know about a bug and a ticket was never submitted, how can the Adalo staff know about the bug and fix it?

@Victor knows what he’s doing :grin: He’s an all-star.

3 Likes

It’s important to mention that I came to the community here only after contacting Adalo.

I received a very bad experience from Adalo’s team, in case you’re wondering. The CX rep said:

“I will log this as a bug that our team can look into. However, I do want to set the expectation that this bug will not be prioritized at this time. I know this is frustrating, and I’m sorry, but we have limited resources and must prioritize issues affecting a larger number of our makers.”

I kept pushing and told him the bug is critical and still persists, and last night he suggested a creative diagnosis: that the bug is caused due to the “Device Detector” I implemented on the page. He deleted it and rebuilt the button and now it works.

However, when I replicated the solution myself and rebuilt the button (while deleting the “Device Detector” component) — the issue continued. I assume that the button that Adalo’s rep built will break down in the near future too, just as what Victor experienced.

I came here to the community as a last resort, unfortunately.

1 Like

Thank you Dilon as well. I really appreciate it.

2 Likes

Hey @Flawless
We are on the same page. I am against a hard approach to moderating forums. It’s tough to convey my sarcasm in plain text, but I am British, it runs in my veins.

The point I was trying to make is that this thread is the perfect example of why this forum is an incredible place for open discussion. Cherry picking the conversations ‘The Company’ want the world to hear would not have brought about this outcome.

Flawless, dilon, victor, and many others… you are in legends status no doubt about it. Myself, I am not in that tier, but I continue to give what I can to the community, even in the oppressiveness of gagging free speech.

Personally, I would throw open the book when it comes to bugs and run it in parallel with the forum.

3 Likes

I believe that everyone in this thread has made their contribution to find some solution for this issue. This is the power of the community :slight_smile:

2 Likes

This is a great suggestion in general. Thank you. Has this ever caused you are alignment issues in app builds like elements not align properly.

C

Not exclusively, I mean there are normally some issues to overcome.
You can’t group an action button in this way, works best for custom buttons you are building.

Adding conditions to every action did turn it off.
In my case, it’s a loading screen I created with a Lottie, where the user goes to after sending a message in the chat screen (in order not to have the messages list in auto-refresh).

The issue I have with “change the input value” here is that I’m not being able to empty it - the user writes a message, hits send, it goes to this loading screen and when it comes back the text input is still full, even though my loading screen as a “change input value” action to “empty”.

Not sure if I understood your issue correctly - nevertheless, one of the ways to “empty” input value is:

  • create a separate screen, disconnected from all others (let’s call it AUXILIARY)
  • add an input there (it might be a good idea to name it smth like “EMPTYINPUT”
  • after that, you can use that “EMPTYINPUT” as a “source” to change other input’s value. E.g. if you need to empty the input on a certain screen, change its value to → other screens → AUXILIARY → EMPTYINPUT.

Hope this helps.

Best,
Victor.

1 Like

Thanks for the tip Victor. Unfortunately it’s still not working for me, and I even have the “change input value” action twice, just to make sure, but it’s not working.

Screen 1 - Chat Screen
Screen 2 - Loading Screen with a Lottie

User writes new message on Screen 1, hits send, it links to Screen 2 that (1) creates the message, (2) updates the conversation, (3) triggers notification, (4) changes the input value of Screen 1 and (4) links back to the Chat Screen.

Additionaly, whenever a user visits Screen 1, there’s again the action of changing the input value to empty (or to the value of this EMPTYINPUT) and it’s not working.

Does the issue persists in case of:

  • you test it in incognito mode from the same browser
  • you test it in another browser?

I’m testing on my phone, both in the previewer and the TestFlight build.