Button can't do more than one "Change Input Value"?

I truly appreciate your assistance, Victor, from the bottom of my heart. I will definitely try the solution you suggested and hopefully, it will solve the issue for good.

1 Like

I disagree, Victor tagging the Adalo staff is a good idea in this situation. If Adalo staff does not know about a bug and a ticket was never submitted, how can the Adalo staff know about the bug and fix it?

@Victor knows what he’s doing :grin: He’s an all-star.


It’s important to mention that I came to the community here only after contacting Adalo.

I received a very bad experience from Adalo’s team, in case you’re wondering. The CX rep said:

“I will log this as a bug that our team can look into. However, I do want to set the expectation that this bug will not be prioritized at this time. I know this is frustrating, and I’m sorry, but we have limited resources and must prioritize issues affecting a larger number of our makers.”

I kept pushing and told him the bug is critical and still persists, and last night he suggested a creative diagnosis: that the bug is caused due to the “Device Detector” I implemented on the page. He deleted it and rebuilt the button and now it works.

However, when I replicated the solution myself and rebuilt the button (while deleting the “Device Detector” component) — the issue continued. I assume that the button that Adalo’s rep built will break down in the near future too, just as what Victor experienced.

I came here to the community as a last resort, unfortunately.

1 Like

Thank you Dilon as well. I really appreciate it.


Hey @Flawless
We are on the same page. I am against a hard approach to moderating forums. It’s tough to convey my sarcasm in plain text, but I am British, it runs in my veins.

The point I was trying to make is that this thread is the perfect example of why this forum is an incredible place for open discussion. Cherry picking the conversations ‘The Company’ want the world to hear would not have brought about this outcome.

Flawless, dilon, victor, and many others… you are in legends status no doubt about it. Myself, I am not in that tier, but I continue to give what I can to the community, even in the oppressiveness of gagging free speech.

Personally, I would throw open the book when it comes to bugs and run it in parallel with the forum.


I believe that everyone in this thread has made their contribution to find some solution for this issue. This is the power of the community :slight_smile:


This is a great suggestion in general. Thank you. Has this ever caused you are alignment issues in app builds like elements not align properly.


Not exclusively, I mean there are normally some issues to overcome.
You can’t group an action button in this way, works best for custom buttons you are building.

Adding conditions to every action did turn it off.
In my case, it’s a loading screen I created with a Lottie, where the user goes to after sending a message in the chat screen (in order not to have the messages list in auto-refresh).

The issue I have with “change the input value” here is that I’m not being able to empty it - the user writes a message, hits send, it goes to this loading screen and when it comes back the text input is still full, even though my loading screen as a “change input value” action to “empty”.

Not sure if I understood your issue correctly - nevertheless, one of the ways to “empty” input value is:

  • create a separate screen, disconnected from all others (let’s call it AUXILIARY)
  • add an input there (it might be a good idea to name it smth like “EMPTYINPUT”
  • after that, you can use that “EMPTYINPUT” as a “source” to change other input’s value. E.g. if you need to empty the input on a certain screen, change its value to → other screens → AUXILIARY → EMPTYINPUT.

Hope this helps.


1 Like

Thanks for the tip Victor. Unfortunately it’s still not working for me, and I even have the “change input value” action twice, just to make sure, but it’s not working.

Screen 1 - Chat Screen
Screen 2 - Loading Screen with a Lottie

User writes new message on Screen 1, hits send, it links to Screen 2 that (1) creates the message, (2) updates the conversation, (3) triggers notification, (4) changes the input value of Screen 1 and (4) links back to the Chat Screen.

Additionaly, whenever a user visits Screen 1, there’s again the action of changing the input value to empty (or to the value of this EMPTYINPUT) and it’s not working.

Does the issue persists in case of:

  • you test it in incognito mode from the same browser
  • you test it in another browser?

I’m testing on my phone, both in the previewer and the TestFlight build.

Then you probably need to submit a support ticket. If you are doing everything correctly, input emptying should work (the one on the 2nd screen; on-screen-enter actions after “back” button don’t usually work).

Or, you can get rid of the 2nd screen (which, in my opinion, is questionable from UX standpoint). But I don’t know the full picture here :slight_smile:


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Hi @TomBlue and everyone,

Adalo released a feature that we can turn off the Instant Navigation option!

Check it out here! : Improved: New Option to Disable Instant Navigation | Adalo Changelog

What Victor mentioned is correct! I just checked turning off that option and booyah it worked! : Change Input Value.mp4 on Vimeo

Thank you

1 Like